Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

New Install, but Admin doesn't work


Guest

Recommended Posts

After I'm told that the installation was successfull, I have trouble with the actually running of the program... I can go to catalog just fine, but the Administration section doesn't work.

 

The error says:

1046 - No Database Selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

The information elsewhere on this site says that the problem is that the configuration file isn't correct if I get this error. The configuration file, however DOES have the correct information:

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'HIDDENFORSDECURITY');

define('DB_SERVER_PASSWORD', 'HIDDENFORSDECURITY');

define('DB_DATABASE', 'HIDDENFORSDECURITY');

 

where 'HIDDENFORSDECURITY' is actually the *correct* information for those places.

 

So... what the heck is wrong here?

 

- sterling

Link to comment
Share on other sites

In case you are not aware there are 2 configure.php files in this program. There is one in the catalog/includes folder and one in the catalog/admin/includes file. I would recheck your settings in the admin file and if that does not work post the entire configure file here with the database info left out. There may be something else not set correctly.

Link to comment
Share on other sites

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'myusername');

define('DB_SERVER_PASSWORD', 'myuserpassword');

define('DB_DATABASE', 'mydatabasename');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

This is what mine is like for the database connection in the admin config file.

Link to comment
Share on other sites

That looks to be correct, but check to make sure that there is no other configure.php file in admin/includes/local/ If a configure.php file exists in the 'local' folder then rename it. It overrides any other configure.php file (if it exists).

 

If that's not it then make sure that your folders have permissions of 755 or 777 - so that the programme can access the folder to read the files inside.

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...