Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL ~ Configuration Problems


SyCoDeath

Recommended Posts

Hi every1. I'm having problems with my SSL. I am using a shared SSL certificate which has been setup for me by my host. But if i use true in the SSL config i just get no page to display. but if i use false i get the pages that require SSL. Please help me i am at my wits end.

Link to comment
Share on other sites

Hi every1. I'm having problems with my SSL. I am using a shared SSL certificate which has been setup for me by my host. But if i use true in the SSL config i just get no page to display. but if i use false i get the pages that require SSL. Please help me i am at my wits end.

 

 

Oh no, not another shared SSL problem! Run for the hills... :'( :blink:

 

Hi Craig, there has been much discussion about shared SSL problems the last several days and you are not the only one seriously miffed about teething issues getting your site to work. Read these two threads on some recent SSL related problems. Oh, and BTW what host are you using out of interest?

 

http://www.oscommerce.com/forums/index.php?showtopic=155437&hl=

http://www.oscommerce.com/forums/index.php?showtopic=155893&hl=

 

Best wishes,

 

David

Link to comment
Share on other sites

Oh no, not another shared SSL problem! Run for the hills...  :'(  :blink:

 

Hi Craig, there has been much discussion about shared SSL problems the last several days and you are not the only one seriously miffed about teething issues getting your site to work. Read these two threads on some recent SSL related problems. Oh, and BTW what host are you using out of interest?

 

http://www.oscommerce.com/forums/index.php?showtopic=155437&hl=

http://www.oscommerce.com/forums/index.php?showtopic=155893&hl=

 

Best wishes,

 

David

Hi David. thanx for your reply.

http://www.1337hosts.com/ thats who i am with. But still having a nitemare with the SSL. i dont really wanna spend out money untill i know the website will work.

Thanx

Link to comment
Share on other sites

Hi David. thanx for your reply.

http://www.1337hosts.com/ thats who i am with. But still having a nitemare with the SSL. i dont really wanna spend out money untill i know the website will work.

Thanx

 

 

Post your configure.php file from catalog/includes without the database connection string at the bottom - also post the path your host has told you to use for the shared SSL

 

also describe your problem in a little more detail - when you say you get no page to display what exactly are you meaning - it may help to set the SSL parameter to true and post your URL so forum can test

 

Charles

A kite flies highest AGAINST the wind !

 

"Life should NOT be a journey to the grave with the intention of arriving safely in an attractive and well preserved body, but rather to skid in sideways, a lover in one hand, martini in the other, body thoroughly used up, totally worn out and screaming ~ WOO HOO!! What a ride!"

Link to comment
Share on other sites

Post your configure.php file from catalog/includes without the database connection string at the bottom - also post the path your host has told you to use for the shared SSL

 

also describe your problem in a little more detail - when you say you get no page to display what exactly are you meaning - it may help to set the SSL parameter to true and post your URL so forum can test

 

Charles

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://sycodeath.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://sycodeath.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'sycodeath.com');

define('HTTPS_COOKIE_DOMAIN', 'sycodeath.com');

define('HTTP_COOKIE_PATH', '/Ultimate.Fantasies/');

define('HTTPS_COOKIE_PATH', '/Ultimate.Fantasies/');

define('DIR_WS_HTTP_CATALOG', '/Ultimate.Fantasies/');

define('DIR_WS_HTTPS_CATALOG', '/Ultimate.Fantasies/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/sdeath/public_html/Ultimate.Fantasies/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

Hi. This is my Config.php file without the database details.

 

The URL is http://sycodeath.com/Ultimate.Fantasies {Adult Store}

 

Well as i try and log in, create account, checkout or anything that needs a secure connection i just get the {The page cannot be displayed} page which makes me think that sumthing serious is wrong. It could be something so simple but i am overlooking. But it only happens when i try and go to a https:// page.

 

The path i have been told to use is sycodeath.com

I am unsure if this is right as i am new to SSL connections

 

Thanx so much in advance

Link to comment
Share on other sites

i dont really wanna spend out money untill i know the website will work

 

In which case - have you actually purchased a full ssl certificate? If you haven't then that's why https links won't work.

 

Your host may offer free use of a shared ssl - but the https address will be different than for a full ssl issued to your website.

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...