Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

PayFlow Pro Nightmare


Guest

Recommended Posts

I have looked and searched the forums for the answers to my Payflow pro questions, have done everything i can find and still no luck getting payflow pro to work.

 

I am on a FreeBSD server 4.8 hosted by Ipower web, the say the dont support .sh on there shared server, i get to enter the card info, review the purchase click confirm and i get a red line accross the top saying CREDIT CARD ERROR! (yes, i installed the fix also)

 

I have been on the phone with verisign, and they cant give me any information that helps, I ran a tes from my personal windows web server and all worked fine.

If anyone who has this running can please guide me to sanity i would appreciate it.

Link to comment
Share on other sites

  • 3 months later...

!!! I've been searching for a fix all day, it's driving me mad. I used to get all the errors, line 169, etc...

 

I've installed the Payflow Pro FIX 1.2.

I've installed Verisign's pfpro into the webroot, keeping the original file structure. I ran the test.sh file, and it connected and returned a proper approved RESULT=0, etc.

I've pointed the /includes/modules/payment/payflowpro.php to the the appropriate file & dirs

 

(i.e. /home/username/www/htdocs/verisign/payflowpro/linux/certs; .../lib; .../bin/pfpro...)

 

When I process the credit card, I don't the php errors, I just get the red bar with "Credit Card Error!"

 

That's as far as I get. No one seems to have an answer for this.

 

PLEASE HELP!

Link to comment
Share on other sites

Well I did everything that the forums suggested

here is the bottom line

 

install the fix as I see you did

enter your server information and upload you files in this manner (or what ever your root server settings are)

/usr/www/users/username/lib

/usr/www/users/username/certs

/usr/www/users/username/bin/pfpro (bin=cgi-bin)

 

 

THE KEY TO IT ALLLLLLLLLLLLLLL!!!!!!!!!!!!!!!!

 

your server MUST support SHELL commands. A shared server will not do, UNLESS it supports SHELL Commands

 

I had to set my customers on a dedicated server, all the other hosting companies I contacted, there shared servers DO NOT SUPPORT SHELL COMMANDS.

 

all the other advice about this is correct, but the server must support shell comands (sorry i cant say that enough)

 

Good luck to you let me know What happens!!

Link to comment
Share on other sites

Well I did everything that the forums suggested

here is the bottom line

 

install the fix as I see you did

enter your server information and upload you files in this manner (or what ever your root server settings are)

/usr/www/users/username/lib

/usr/www/users/username/certs

/usr/www/users/username/bin/pfpro (bin=cgi-bin)

THE KEY TO IT ALLLLLLLLLLLLLLL!!!!!!!!!!!!!!!!

 

your server MUST support SHELL commands. A shared server will not do, UNLESS it supports SHELL Commands

 

I had to set my customers on a dedicated server, all the other hosting companies I contacted, there shared servers DO NOT SUPPORT SHELL COMMANDS.

 

all the other advice about this is correct, but the server must support shell comands (sorry i cant say that enough)

 

Good luck to you let me know What happens!!

 

 

thanks... I've done all this. I have SSH access to my server, and I can execute .sh commands without any problems, esspecially the test.sh that came with payflowpro, and it works perfectly fine, and the test transaction is there and everything. I'm pretty much stumped. Unless SHELL Command support is different, I don't know what else to try.

 

My client only a year in with their 2 year contract with Versign, so I can't change CC Gateways anything soon.

Link to comment
Share on other sites

  • 4 weeks later...

I'm having exactly the same problem - is there any answers to this????

 

Strange though, our site has been working for over 6 months using oscommerce & payflowpro, now all of a sudden we are getting this credit card error! & haven't found any logical reason why the connection now doesn't work.

 

We have shell access & have successfully processed transactions to the payflowpro account. But as soon as you go back & try to process a transaction in the cart you get the dreaded error message

 

Can anyone please help? :o

Link to comment
Share on other sites

  • 2 weeks later...

OK our nightmare is over and I want to share the experience with those of you who are having the same issue. So here it goes.

 

2 days ago our server crashed when we tried to update plesk. It went back on shortly afterwards but we realized that although no information was lost, credit card transactions are not going through. Nothing was changed, so we assumed that the crash corrupted the SDK file. We proceed to download the new SDK file, untarred it in the same folders, test.sh (we are on a linux server) went through fine and VeriSign confirms it, but OSCOMMERCE just wouldn't work. So what the hell was the problem.

 

We chmod 777 to the pfpro module, bin, the lib, and then set the CERT PATH in ssh, export it, and even verified it with env|grep. Everything was OK but as soon as the information is going to be transferred to VeriSign it returns the dreadful CREDIT CARD ERROR.

 

In the end it was Cardinal Commerce that helped us. We have Cardinal Commerce's modified PayFlowPro modules because we were using them as our Verified by VISA/Master Secured Code validator. Jeff from Cardinal Commerce was extremely helpful, even stuck with me for 45 minutes trying to help us figure out the problem (not to mention doing personal searches on google, verisign). They were even more helpful than VeriSign tech support, who still has not called us after a day.

 

Anyway, within the cardinal modified PFPRO module, there's an option that outputs all the card transaction information to the error log (php.log). From there we found out that these error messages were present in every failed attempt:

 

[17-Nov-2005 12:53:22] PHP Warning: putenv(): Safe Mode warning: Cannot override protected environment variable 'LD_LIBRARY_PATH' in /home/httpd/vhosts/audiocubes.com/httpdocs/includes/functions/php_pfpro.php on line 149

[17-Nov-2005 12:53:22] PHP Warning: putenv(): Safe Mode warning: Cannot set environment variable 'PFPRO_CERT_PATH' - it's not in the allowed list in /home/httpd/vhosts/audiocubes.com/httpdocs/includes/modules/payment/payflowpro.php on line 242

 

Turned out that after our server went down, when it was back on, PHP was in safe mode. Our tech support disable safe mode in the local value, but that wasn't enough. As soon as local and master value of Safe mode are disabled, eveything went through correctly. This was the last thing we thought of. If we did not have that debugging information god knows when this problem can be resolved. I hope our experience will help some what for you people out there looking at that bright red error message. Good luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...