Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

can't leave the home page


kpatrick

Recommended Posts

my servers switched my site over a couple days ago and i've FINALLY got everything almost back to normal. except now, any time i click on ANY of the links on the home page, it adds the DIR_WS_ADMIN/page name to the links. i've seached this site literally for about 6 hours today tring to figure something out. any thoughts on where i should start first? i'm seriously about to throw my monitors out the window

Link to comment
Share on other sites

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.flammableclothing.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.flammableclothing.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/store');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/store/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/fcdesigns/flammableclothing.com/store/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'store.*****.com'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '*******');

define('DB_SERVER_PASSWORD', '*******');

define('DB_DATABASE', 'flammableclothing');

define('USE_PCONNECT', 'true'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

look in the includes/local directory for a configure.php file, if there delete it

 

dir dir_ws_admin is used only in admin, not the front page

Link to comment
Share on other sites

look in the includes/local directory for a configure.php file, if there delete it

 

dir dir_ws_admin is used only in admin, not the front page

 

there isn't a configure.php file in that folder. and i'll try to figure out that global contribution tomorrow, right now its not makin too much sense to me. i'll try and read on it some more tomorrow

Link to comment
Share on other sites

i got past the register_globals, the host may have redone something.

still thinking it is the /store/includes/configure.php file wrong. is this a template you got from somewhere? and is it a full load of osc or a take off?

Link to comment
Share on other sites

i got past the register_globals, the host may have redone something.

still thinking it is the /store/includes/configure.php file wrong.  is this a template  you got from somewhere?  and is it a full load of osc or a take off?

the site is from a template but the code looks the same as the fresh install configure.php file

Link to comment
Share on other sites

the site is from a template but the code looks the same as the fresh install configure.php file

 

any other thoughts? i've tried restoring just about every file and i can't seem to figure out what it is

 

just for example this is what EVERY link on the page looks like

 

http://thenameofthestore.comdir_ws_adminpr...d=8798798798797

Link to comment
Share on other sites

take a configure.php from an original copy of osCommerce, place it in there, with the editing done. see what happens.

Link to comment
Share on other sites

there has got to be some other problem or the document root is set wrong on the server, etc, as dir_ws_admin is not listed in the regular catalog anywhere.

setup another directory of oscommerce, with the generic installation, no templates, no add ons and see what you get. that takes about 10 minutes to do if you have to download osc

Link to comment
Share on other sites

there has got to be some other problem or the document root is set wrong on the server, etc, as dir_ws_admin is not listed in the regular catalog anywhere.

setup another directory of oscommerce, with the generic installation, no templates, no add ons and see what you get.  that takes about 10 minutes to do if you have to download osc

 

something is just royally screwed. i'm just going to redo the whole site.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...