Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR


Darklings

Recommended Posts

Hi,

 

I just installed Easyphp (a complete package with mysql, apache, php and phpmyadmin -> easy to install) but encountered a problem.

 

My site works online but i wanted this testserver localy to test faster. When I surf to my http://localhost/catalog i get this error:

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I checked the php.ini and changed the register_globals to yes, but it still gives the same error. Can someone help me pls??

 

Kind Regards,

Tom

Even in this dark place, yes, I am afraid of my own shadow.

 

 

 

Contributions | KnowledgeBase | osCommerce 2.2 pdf

Link to comment
Share on other sites

Which one did you change?

Change the one you can acces by the Easyphp panel (rightclick on icon in taskbar.

Choose configuration -> php

Forum search

Contributions search

Documentation search (note: docs being adapted for MS3, may be different for MS2)

3 tips for better forum searching

 

Want to post? Read this first:

osCommerce for dummies

Topic name etiquette

 

Basics:

Basics for design

Right syntax to use near '-20, 20'

Cannot re-assign $this

Parse error

Link to comment
Share on other sites

register_globals to yes

 

Also, you should set it to on not yes. On first read I thought you meant you turned registered_globals on, but of course I don't know if you meant that. Or you actually set it to yes

Forum search

Contributions search

Documentation search (note: docs being adapted for MS3, may be different for MS2)

3 tips for better forum searching

 

Want to post? Read this first:

osCommerce for dummies

Topic name etiquette

 

Basics:

Basics for design

Right syntax to use near '-20, 20'

Cannot re-assign $this

Parse error

Link to comment
Share on other sites

I'm sorry, i should have written it out clearer... I changed it in my php.ini to : - register_globals = on

 

I just dont understand it.. i Changed two php.ini's.. one who was in my folder php and on in my folder apache. Then i did what you said, about the configure from the easyphp icon, and there it wasnt changed yet - so i changed it there now to.

 

Still i get the same result........

Even in this dark place, yes, I am afraid of my own shadow.

 

 

 

Contributions | KnowledgeBase | osCommerce 2.2 pdf

Link to comment
Share on other sites

Make sure you didn't change this line:

; - register_globals = Off         [Security, Performance]

 

But this line:

; You should do your best to write your scripts so that they do not require
; register_globals to be on;  Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
register_globals = Off

Forum search

Contributions search

Documentation search (note: docs being adapted for MS3, may be different for MS2)

3 tips for better forum searching

 

Want to post? Read this first:

osCommerce for dummies

Topic name etiquette

 

Basics:

Basics for design

Right syntax to use near '-20, 20'

Cannot re-assign $this

Parse error

Link to comment
Share on other sites

Look in C:\Windows for another php.ini

 

Vger

 

 

Hum, i dont have a php.ini in my c:\WinNT

 

I only have 3 php.ini files..

 

one in my c:\easyphp\php

one in my c:\easyphp\apache

and one in my c:\easyphp\conf_files

 

In all 3 of those files register_globals = On

 

 

ex.

 

; - register_globals = On [security, Performance]

; Global variables are no longer registered for input data (POST, GET, cookies,

; environment and other server variables). Instead of using $foo, you must use

; you can use $_REQUEST["foo"] (includes any variable that arrives through the

; request, namely, POST, GET and cookie variables), or use one of the specific

; $_GET["foo"], $_POST["foo"], $_COOKIE["foo"] or $_FILES["foo"], depending

; on where the input originates. Also, you can look at the

; import_request_variables() function.

; Note that register_globals is going to be depracated (i.e., turned off by

; default) in the next version of PHP, because it often leads to security bugs.

; Read http://php.net/manual/en/security.registerglobals.php for further

; information.

 

:x :s :x

Even in this dark place, yes, I am afraid of my own shadow.

 

 

 

Contributions | KnowledgeBase | osCommerce 2.2 pdf

Link to comment
Share on other sites

LOL I had the same problem when first using easyphp

 

My solution was to copy/paste php.ini from

 

easyphp\php

to

easyphp\conf_files

 

Only later I noticed I changed the wrong one :blush:

Forum search

Contributions search

Documentation search (note: docs being adapted for MS3, may be different for MS2)

3 tips for better forum searching

 

Want to post? Read this first:

osCommerce for dummies

Topic name etiquette

 

Basics:

Basics for design

Right syntax to use near '-20, 20'

Cannot re-assign $this

Parse error

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...