Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Adding Flash in "Product Description" Field


Mediajuggle

Recommended Posts

I'm trying to add code for a flash music player in the Product Description field...

 

when i add the following code in the field:

 

<center>
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="500" height="400" 
 codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0">
 <param name="movie" value="mp3player.swf" />
 <param name="quality" value="high" />
 <param name="wmode" value="transparent">
 <embed src="http://www.musica360.com/player/lcp/mp3player.swf" quality="high" width="500" height="400" wmode="transparent"
   type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

 

And go to the Preview Page the player shows up but doesn't work and won't read the XML file.

when i "go back: to the Products Description Page the code looks like this:

 

<center>
<object classid=\"clsid:d27cdb6e-ae6d-11cf-96b8-444553540000\" width=\"500\" height=\"400\" 
 codebase=\"http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0\">
 <param name=\"movie\" value=\"mp3player.swf\" />
 <param name=\"quality\" value=\"high\" />
 <param name=\"wmode\" value=\"transparent\">
 <embed src=\"http://www.musica360.com/player/lcp/mp3player.swf\" quality=\"high\" width=\"500\" height=\"400\" wmode=\"transparent\"
   type=\"application/x-shockwave-flash\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\" />
</object>

 

The player does work because if you go directly to:

http://www.musica360.com/player/lcp/mp3player.swf

 

the player works fine...

 

what am I doing wrong?

My Contribution

Music Download Store Template

http://www.oscommerce.com/community/contributions,4275

Link to comment
Share on other sites

anyone with any ideas?

 

looks like the "\" may be screwing it up...

 

my flash player works, and this is my code copied directly from my product:

<b>Jail Ain't No Place For Feelin' Lonesome<br>
James Junkin Jr. & Jim Gunning </b><br>
single song download<br>
<font size="-1"><b>from the CD Swamp Music</b></b></font></b><br> 
44.1 192 kbps mp3<br>
5:29 min<br>
? 2005
<table summary="" border="0">
<tr>
 <td><font size="-2"> play lo-fi </font></td>
 <td><object type="application/x-shockwave-flash"
data="http://www.jamesjunkinjr.com/m3u/musicplayer.swf?playlist_url=http://www.jamesjunkinjr.com/m3u/jaillo.xspf&repeat_playlist=false&autoplay=false" 
width="17" height="17">
<param name="menu" value="false" /><param name="wmode" value="transparent" />
<param name="movie" 
value="http://www.jamesjunkinjr.com/m3u/musicplayer.swf?playlist_url=http://www.jamesjunkinjr.com/m3u/jaillo.xspf&repeat_playlist=false&autoplay=false" />
<img src="noflash.gif" 
width="17" height="17" alt="" />
</object></td>
 <td><font size="-2"> play hi-fi </font></td>
 <td><object type="application/x-shockwave-flash"
data="http://www.jamesjunkinjr.com/m3u/musicplayer.swf?playlist_url=http://www.jamesjunkinjr.com/m3u/jail_hi.xspf&repeat_playlist=false&autoplay=false" 
width="17" height="17">
<param name="menu" value="false" /><param name="wmode" value="transparent" />
<param name="movie" 
value="http://www.jamesjunkinjr.com/m3u/musicplayer.swf?playlist_url=http://www.jamesjunkinjr.com/m3u/jail_hi.xspf&repeat_playlist=false&autoplay=false" />
<img src="noflash.gif" 
width="17" height="17" alt="" />
</object></td>
</tr>
</table>

 

I'm new to osCommerce, and I'm getting confused a bit with sql and php, but my player works

 

hope that helps

cheers

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...