Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL configuration


Guest

Recommended Posts

I am having problems getting the SSL to work.

 

I have ready a thread by Simplyeasier that describes the SSL setup process.

 

I have a dedicated IP address.

I obtained a SSL key, certificate and CSR from my host provider. the certificate files look like "safetalks.net"

I updated the configure files in the include and the admin/include directory.

 

Here is one file.

admin/include/configure.

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.safetalks.net'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.safetalks.net');

define('HTTPS_CATALOG_SERVER', 'https://safetalks.net');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/home/safecell/public_html/catalog/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/safecell/public_html/catalog/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_FS_CATALOG', '/home/safecell/public_html/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'safecell_1prod2z');

define('DB_SERVER_PASSWORD', 'zaq1234');

define('DB_DATABASE', 'safecell_myprod');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

 

I asked my host provider to restart the HTTPD files. I just cannot get the SSL to work.

 

I should mention that the web pages are located in a different folder on the server. My root directory has a bunch of admin folders. My webpages are located in a folder called web. In this folder is the index page of my site and the catalog folder. The SSL folder is in the root.

 

I am unsure what the problem is. Can you please help.

Link to comment
Share on other sites

I am having problems getting the SSL to work.

 

I have ready a thread by Simplyeasier that describes the SSL setup process.

 

I have a dedicated IP address.

I obtained a SSL key, certificate and CSR from my host provider. the certificate files look like "safetalks.net"

I updated the configure files in the include and the admin/include directory.

 

Here is one file.

admin/include/configure.

<?php

/*

  osCommerce, Open Source E-Commerce Solutions

  http://www.oscommerce.com

 

  Copyright ? 2003 osCommerce

 

  Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

  define('HTTP_SERVER', 'http://www.safetalks.net'); // eg, http://localhost - should not be empty for productive servers

  define('HTTP_CATALOG_SERVER', 'http://www.safetalks.net');

  define('HTTPS_CATALOG_SERVER', 'https://safetalks.net');

  define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

  define('DIR_FS_DOCUMENT_ROOT', '/home/safecell/public_html/catalog/'); // where the pages are located on the server

  define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required

  define('DIR_FS_ADMIN', '/home/safecell/public_html/catalog/admin/'); // absolute pate required

  define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

  define('DIR_FS_CATALOG', '/home/safecell/public_html/catalog/'); // absolute path required

  define('DIR_WS_IMAGES', 'images/');

  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

  define('DIR_WS_INCLUDES', 'includes/');

  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

  define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

  define('DB_SERVER_USERNAME', 'safecell_1prod2z');

  define('DB_SERVER_PASSWORD', 'zaq1234');

  define('DB_DATABASE', 'safecell_myprod');

  define('USE_PCONNECT', 'false'); // use persisstent connections?

  define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

 

I asked my host provider to restart the HTTPD files.  I just cannot get the SSL to work.

 

I should mention that the web pages are located in a different folder on the server. My root directory has a bunch of admin folders.  My webpages are located in a folder called web. In this folder is the index page of my site and the catalog folder.  The SSL folder is in the root.

 

I am unsure what the problem is. Can you please help.

 

What exactly is the error you are getting when you say you cannot get it to work ?

 

Charles

A kite flies highest AGAINST the wind !

 

"Life should NOT be a journey to the grave with the intention of arriving safely in an attractive and well preserved body, but rather to skid in sideways, a lover in one hand, martini in the other, body thoroughly used up, totally worn out and screaming ~ WOO HOO!! What a ride!"

Link to comment
Share on other sites

What exactly is the error you are getting when you say you cannot get it to work ?

 

Charles

 

 

When I look at the ADMIN panel I see the statement " You are not protected by a secure SSL connection."

 

When I attempt to use the catalog. Ie create a new account checkout. Anyway to access the Https: files I get a error message " The pages cannot be displayed" although the address is an https address

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...