Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Client denied by server configuration


andyfv

Recommended Posts

Hello,

 

Got a problem with the latest version of osCommerce...

 

The pre-installation tasks were carried out, with the CHMOD of the configure.php to 777 (and other permissions all with the same outcome). register_globals has been put on in the php.ini.

 

The problem is as follows: The installation fails after the database information has been entered, ie. it fails while trying to import, getting no error other than a half loaded screen, and you can go no further. When trying to get to: catalog/includes/configure.php, i get a 403 Forbidden error, and this appears in the log:

 

[DATE] [error] [client IP] client denied by server configuration: /USERDIRLOCATION/www/catalog/includes/configure.php

 

When trying to get to catalog/admin/includes/configure.php i get a blank loaded page.

 

What is this a problem with? Are there more settings in php.ini that need to be enabled.

 

Can anyone help me? Thanks in advance...

 

--Andy

Link to comment
Share on other sites

Hello,

 

Got a problem with the latest version of osCommerce...

 

The pre-installation tasks were carried out, with the CHMOD of the configure.php to 777 (and other permissions all with the same outcome). register_globals has been put on in the php.ini.

 

The problem is as follows: The installation fails after the database information has been entered, ie. it fails while trying to import, getting no error other than a half loaded screen, and you can go no further. When trying to get to: catalog/includes/configure.php, i get a 403 Forbidden error, and this appears in the log:

 

[DATE] [error] [client IP] client denied by server configuration: /USERDIRLOCATION/www/catalog/includes/configure.php

 

When trying to get to catalog/admin/includes/configure.php i get a blank loaded page.

 

What is this a problem with? Are there more settings in php.ini that need to be enabled.

 

Can anyone help me? Thanks in advance...

 

--Andy

 

I'm now getting the following error, found on the bug reports;

 

Fatal error: Call to undefined function: mysql_connect() in /var/www/html/catalog/admin/includes/functions/database.php on line 19

 

Which states 'You do not have mysql complied into php'.

 

Anybody know which modules i need/how to fix this?

 

--Andy

Link to comment
Share on other sites

If you don't have mysql then you're out of luck. Unless you have your own dedicated server it's not something you can add.

 

However, have you tried creating a blank mysql database, via your wbe hosting control panel?

 

It is a pre-requisite before starting the install procedure. There is an installation guide in the Knowledge Base.

 

Vger

Link to comment
Share on other sites

If you don't have mysql then you're out of luck.  Unless you have your own dedicated server it's not something you can add.

 

However, have you tried creating a blank mysql database, via your wbe hosting control panel?

 

It is a pre-requisite before starting the install procedure.  There is an installation guide in the Knowledge Base.

 

Vger

 

I've fixed that problem. MySQL was on a remote server, without a local copy, the pre-compiled PHP mysql modules were not sufficent. Fixed by installing a OS supported version of MySQL locally, and changing location on PHP compile. Cheers.

 

--Andy

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...