Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Missing Credit Card Data


mamaflee

Recommended Posts

Hi!

 

I was doing final run-throughs on our cart before making it "live" and realized that if we don't do the split number for credit cards, all that shows in the order area is "credit card". No numbers, info, etc.

 

So I tried using the split method (as it's more secure anyway) and it did what it should - e-mailing me the middle numbers, and when viewing the orders I can see the other numbers. However, there is no info listed for date or name. All I get are the cc numbers.

 

I have done modifying on the cart - could I have modified something that is causing this problem? (but I have not done any mods to the payment options) What info would be helpful to troubleshoot this?

 

Thank you in advance,

 

Amy

Link to comment
Share on other sites

Anyone? LOL

 

Even a tip as to what files to check? Order.php? One of the checkout files?

 

I just don't even know where to start looking - but I can't accept cc's without being able to see the dates/type, and ower.

 

Thanks again!

 

Warmly,

Amy

Link to comment
Share on other sites

I thought I had the same problem in the beginning. Then, found that the info was on the order when you print it out from the admin page. Go to customers, then orders, then any order. Click on Details and all the info should be on that page. Good Luck!!!

Link to comment
Share on other sites

I thought I had the same problem in the beginning.  Then, found that the info was on the order when you print it out from the admin page.  Go to customers, then orders, then any order.  Click on Details and all the info should be on that page.  Good Luck!!!

 

 

Hi!

 

Thanks for the feedback - but mine really isn't there.

 

It will say Payment Method Credit Card.

Credit Card Type: (blank)

Name: (blank)

Exp. Date: (blank)

Number: 1234xxxxxxxx1111

 

So for some reason I get the credit card numbers, but not the rest of the data the customer entered.

 

Thanks for trying!!! :)

 

Warmly,

Amy

Link to comment
Share on other sites

Ok - more info. I'm not sure if it's helpful or not, but what the heck.

 

I looked in the sql database and it is not showing any name/exp/card type either. But it will show the split cc number.

 

So the data is not writing to the sql database is my guess - again, anyone know where to look for the root of that problem??? Customer is asked to input the info, order goes through fine, but select cc data is missing.

 

Help! (still, LOL)

 

Thank you!

Amy

Link to comment
Share on other sites

Amy, I'm not getting any details whatsoever. I did however get the middle numbers once that option was selected, but in the order admin, all I get is the following:

 

ccdetails.jpg

 

I'd appreciate pointers, and shall remain searching in the hope of getting an answer to this problem, but please do respond if you have a solution.

Link to comment
Share on other sites

Amy, I'm not getting any details whatsoever. I did however get the middle numbers once that option was selected, but in the order admin, all I get is the following:

 

ccdetails.jpg

 

I'd appreciate pointers, and shall remain searching in the hope of getting an answer to this problem, but please do respond if you have a solution.

 

Hi!

 

I wish I could help you - I actually am hiring someone to troubleshoot and fix it. Wish I had more help!!!

 

Warmly,

Amy

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...