Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

File Permissions on configure.php


Nokinja

Recommended Posts

After installing the application and setting the correct permissions (777) I'm still getting a warning at my catalog which says

Warning: I am able to write to the configuration file: /services/webpages/t/r/xxxxxxx/public/oscommerce/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

I cannot get this to go away... Any ideas?

Link to comment
Share on other sites

After installing the application and setting the correct permissions (777) I'm still getting a warning at my catalog which says

I cannot get this to go away... Any ideas?

 

 

Dont know where you read that but you read it wrong - permisions need to be 444 or better 400 NOT 777

 

Charles

A kite flies highest AGAINST the wind !

 

"Life should NOT be a journey to the grave with the intention of arriving safely in an attractive and well preserved body, but rather to skid in sideways, a lover in one hand, martini in the other, body thoroughly used up, totally worn out and screaming ~ WOO HOO!! What a ride!"

Link to comment
Share on other sites

How are you changing the permissions? If you are hosted on a Windows server then trying to use the chmod command via FTP will not work.

 

If you are on a Unix or linux type server and you have changed permissions to 444 then try deleting all Temporary Internet Files and all Offline Content from your browser. You may be looking at an old cached version of that page.

 

If that doesn't work then try setting permissions to 400.

 

And finally, if that doesn't work then you'll have to upload a file to change the permissions. You can PM me for the details on that.

 

Vger

Link to comment
Share on other sites

I am having this same issue. I am using CuteFTP7 to edit my configure.php file.

 

When I try to change permissions to 400 it automatically changes it back to 644.

 

Any idea how to change this permanently?

Link to comment
Share on other sites

I am having this same issue. I am using CuteFTP7 to edit my configure.php file.

 

When I try to change permissions to 400 it automatically changes it back to 644.

 

Any idea how to change this permanently?

 

Just an addition;

 

Tried changing permissions through my Cpanel. Getting the same thing. CHnages from 444 back to 644 automatically.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...