Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL problem


spiderserve

Recommended Posts

Hi,

 

I am new to SSL and am having a few problems...

 

Our ISP has installed our cert and we are on a shared SSL server.

 

When I click to login, the redirection points to the correct place and uses https:// but I get the page cannot be displayed message.

 

admin/includes/configure.php file:

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

  define('HTTP_SERVER', 'http://217.72.180.236/~soft34829'); // eg, http://localhost - should not be empty for productive servers

  define('HTTP_CATALOG_SERVER', 'http://217.72.180.236/~soft34829');

  define('HTTPS_CATALOG_SERVER', 'https://217.72.180.236/~soft34829');

  define('ENABLE_SSL_CATALOG', true); // secure webserver for catalog module

  define('DIR_FS_DOCUMENT_ROOT', '/home/.sites/51/site45/web/Tradezone/shop/catalog/'); // where the pages are located on the server

  define('DIR_WS_ADMIN', '/Tradezone/shop/catalog/admin/'); // absolute path required

  define('DIR_FS_ADMIN', '/home/.sites/51/site45/web/Tradezone/shop/catalog/admin/'); // absolute pate required

  define('DIR_WS_CATALOG', '/Tradezone/shop/catalog/'); // absolute path required

  define('DIR_FS_CATALOG', '/home/.sites/51/site45/web/Tradezone/shop/catalog/'); // absolute path required

 

includes/configure.php file

// Define the webserver and path parameters

 

// * DIR_FS_* = Filesystem directories (local/physical)

 

// * DIR_WS_* = Webserver directories (virtual/URL)

 

 

define('HTTP_SERVER', 'http://217.72.180.236/~soft34829'); // eg, http://localhost - should not be empty for productive servers

 

define('HTTPS_SERVER', 'https://217.72.180.236/~soft34829'); // eg, https://localhost - should not be empty for productive servers

 

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

define('HTTP_COOKIE_DOMAIN', '217.72.180.236/~soft34829');

 

define('HTTPS_COOKIE_DOMAIN', 'https://217.72.180.236/~soft34829');

 

define('HTTP_COOKIE_PATH', '/Tradezone/shop/catalog/');

 

define('HTTPS_COOKIE_PATH', '/Tradezone/shop/catalog/');

 

define('DIR_WS_HTTP_CATALOG', '/Tradezone/shop/catalog/');

 

define('DIR_WS_HTTPS_CATALOG', '/Tradezone/shop/catalog/');

 

define('DIR_WS_IMAGES', 'images/');

 

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

 

define('DIR_WS_INCLUDES', 'includes/');

 

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

 

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

 

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

 

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

 

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

 

define('DIR_FS_CATALOG', '/home/.sites/51/site45/web/Tradezone/shop/catalog/');

 

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

 

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

Could the problem I am having be something to do with the fact that we don't have the domain name pointing to the Ip address?

It's a pain in the neck as this is the 3rd time we have had to change servers this year...

 

If we can sort this out without having to point the domain name at the IP address until we are ready to go live, I will be a very happy bunny!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...