Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

problem when changing title in product_info.php


dogmir

Recommended Posts

using the contribute it says to change this in the product_info.php:

 

 

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>

change to this:

<?php
$the_product_info_query = tep_db_query("select pd.language_id, p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_retail_price,  p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "'" . " and pd.language_id ='" .  (int)$languages_id . "'"); 
   $the_product_info = tep_db_fetch_array($the_product_info_query);
$the_product_name = strip_tags ($the_product_info['products_name'], "");
$the_product_description = strip_tags ($the_product_info['products_description'], "");
$the_product_model = strip_tags ($the_product_info['products_model'], "");?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?> :: <?php echo $the_product_name; ?></title>

 

 

when i do what it says in that contrib and change the code in the product_info.php the category that list the products still says heading_title and when you click on the product it says

 

 

1054 - Unknown column 'p.products_retail_price' in 'field list'

 

select pd.language_id, p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_retail_price, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from products p, products_description pd where p.products_id = '31' and pd.products_id = '31' and pd.language_id ='1'

 

[TEP STOP]

Link to comment
Share on other sites

which contribution are you installing? What is the link to that contrib?

 

It sounds like the contrib also adds tables to your SQL database. Is there a .sql file included? Did you add it to your database with phpMyAdmin?

 

-jared

Link to comment
Share on other sites

The sub category pages are not product_info pages - - are you sure you followed the installation instructions properly?

 

-jared

Link to comment
Share on other sites

He's got it fixed now, I think... was missing the one bit of code for the part of index.php that lists all the products for a category.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...