Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Add To cart not working


Guest

Recommended Posts

Hey I am having troubles with my add to cart button after my product descriptions. When I click 'add to cart' it just refreshes the page and doesnt add anything. BUT when I view the product in list form i can click the 'buy now' and it adds the product to the cart. I am using the sts template system...but im not sure really if that is the problem or what.

 

Here is a link to my site:

 

ICF STORE

 

Any Help would Be GREATLY appreciated! :D

Link to comment
Share on other sites

  • 2 weeks later...

Please I still need help!!

 

When i click add to cart the first time, the resulting page is the same but the link in the address bar changes:

 

/product_info.php/products_id/34&action/add_product?osCsid=a73296c61d12abf2058526981a46e5af

 

When i click the second time (trying to add to cart once more) I still get directed to the same page, nothing in cart with this link in the address bar:

 

/product_info.php/products_id/34%26action&action/add_product?osCsid=a73296c61d12abf2058526981a46e5af

 

I really would like to get this fixed. I am using the STS template system. Any help would be oh so greatly appreciated. Thank you for your time - Peter

Link to comment
Share on other sites

quote

I am using the sts template system...but im not sure really if that is the problem or what

 

Well, if the problem started after you installed it, it's a fairly safe bet it is.

IMO the STS just messes things up so it's twice as hard to fault find when things go wrong... sorry I can't be more help.

 

Try turning "SEO Friendly URLs" off in your Admin to see if that helps.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...