Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Site Testing on a Local Server


Sierrab

Recommended Posts

So far So Good, although a bit of a struggle I am in the throes of building a shop selling mp3 and flac files. I am constructing it on my local server. I have installed the Download controller and all seems to be working but I need a way of persuading my set up that payment has been authorised, so that I can check the download.

 

I get to the final page of the shopping process OK but am left with the message

"NOTE: Downloads are not available until payment has been confirmed"

 

Is there a way around this?

 

Also is there alive shop selling MP3s in single and album format that anyone can point me to?

 

OSC is an awesome invention...I wish I had discovered it earlier

 

Thanks in advance

 

Steve

Link to comment
Share on other sites

As a work around to test my site purely on a local host set up I have set the product price to zero which will allow me to use the Webmasters Corner CC. All works fine until I get to the final page where I can see the file ready for download but with no link so am unable to download!!

 

I have double checked the installation of the downloads controller files...they see to be OK.

 

Both the public and the download folders have read/write permissions. Any thoughts??

 

 

 

Steve

Link to comment
Share on other sites

Having double checked the properties on the 2 folders I have found that they have reverted to having the "Read Only" box contain a grey tick....I have tried all the settings in Windows properties to clear the box but it keeps reverting to a grey tick in the Read Only box. I have allowed sharing etc....

 

How do I set these files to have the right attributes locally?

 

Ah the joys of taking a stab!!

 

Steve

Link to comment
Share on other sites

Silly me!!

 

Found (a) fault in file naming.

 

At last the download button appears!!!!!!!!

 

However when I slick on the button and am prompted for Save As I only get the first word of the song with no file suffix.

 

It should read The Island.wma but I only get The

 

Any ideas out there

 

Steve

Link to comment
Share on other sites

By adding an underscore to the file name.......all is well.

 

Just posting on the forum seems to do the trick, I just wait an hour or two and I find the solution!!

 

Onwards

 

Many thanks for the use of the space!!??

 

Steve

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...