Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can this shopping cart EVER be trusted???


bugleman

Recommended Posts

What happened???

 

My tax shows 8.1 % but it is charging 50% !!

 

So....I deleted all tax info. Everything is set at zero. STILL it is charging 50%.

 

In checkout it shows a bunch of plus signs in front of the tax amount. Is that a clue for anyone who might know what is going on?

 

I'm soooo glad I happened to catch this. I don't know how long this has been like this but I haven't made a sale in awhile. duh! I wonder why!

 

HELP!!

Link to comment
Share on other sites

What happened???

 

My tax shows 8.1 % but it is charging 50% !!

 

So....I deleted all tax info.  Everything is set at zero.  STILL it is charging 50%.

 

In checkout it shows a bunch of plus signs in front of the tax amount.  Is that a clue for anyone who might know what is going on?

 

I'm soooo glad I happened to catch this.  I don't know how long this has been like this but I haven't made a sale in awhile.  duh!  I wonder why!

 

HELP!!

 

Is it a stock oSC or have you added contributions like ezier new fields etc..?

Link to comment
Share on other sites

Is it a stock oSC or have you added contributions like ezier new fields etc..?

 

It's what came with the shopping cart originally. The only contributions I've added are for payment modules. I did just add the PayPal IPN. Would that have done something?

 

It seems to be multiplying the tax by about 6 times what it's supposed to be. The tax shows five plus signs in front of it.

Link to comment
Share on other sites

I think I know what it's doing now but don't know how to fix it.

 

I keep changing the taxes back to zero and redoing the zone, etc. to try to fix it. Each time I've done that makes the tax multiply by one more time in my checkout. So I've tried fixing it six times and it's multiplying the tax amount by six times.

 

Does anyone know why it's doing this and how to fix it?

Link to comment
Share on other sites

It would appear that your database is not updating correctly e.g. you delete something in 'admin' but it's not deleted in the database, so when you re-add it in 'admin' it is multiplying. Quickest (temporary) fix is to access your database via phpMyAdmin and delete all the extra tax classes that have accumulated. Longer term you will have to find out why your database is not updating correctly.

 

Vger

Link to comment
Share on other sites

Thanks for the suggestion. What you're saying makes sense as far as I understand what you mean but I don't know how to find what you're saying. I'm not clear on where I go and how to fix it. Sorry. :( Can you give me a little more info on what to do?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...