Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HELP Configure.php won't update


anyamoo

Recommended Posts

OK - Hi all

 

I have read and re-read the instructions, I have changed both permissions to admin/includes/configure.php & includes/configure.php to 644 AND 444

 

each time I change one, the other refreshes back to 777.

 

I have searched the forum and read all possible threads re this, but not seen one in connection to how to tackle this problem, apart from one suggesting a change of host - well that's not going to happen!

 

So does anyone know how I can get these pesky configure files to stay at 644 or 444 without refreshing so I can get on and make the site look pretty???

 

PS my operating system is Linux and I use SmartFTP...

 

I was hoping OS Commerce would be better than my current shop cubecart, but so far nowt but problems in setting up so all and any advice gratefully received

 

thanks

Link to comment
Share on other sites

Contact your host as they may not be allowing you to set permissions, that or use a different ftp program such as ws_ftp

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

Contact your host as they may not be allowing you to set permissions, that or use a different ftp program such as ws_ftp

 

thanks - ws_ftp did not work, I have contacted my host but it is unlikely they have prevented me from setting permissions especially since one can be set perfectly, its just when I set the other that the refresh happens.

 

any other suggestions just in case host comes back and says its not them (I know the guys who I host with, and I am pretty sure this will be the case) or should I give up and look for another shop software package?

Link to comment
Share on other sites

I have the exact same problem. My host changed both the configure files for me and it secures the first page, but not the next page. My host told me to ask you guys.

I've been dealing with this problem for a few days now. I need help too!

 

Thanks.

Link to comment
Share on other sites

Create a new text file on your computer, and then rename it to chmod.php

 

Inside the file enter this code (to alter file permissions of admin/includes/configure.php):

 

<?php

chmod ("configure.php", 0444);

?>

 

Upload this to the admin/includes/ folder, and then type this into your browser:

 

http://www.yourdomain.com/admin/includes/chmod.php

 

This should change the file permission.

 

Vger

Link to comment
Share on other sites

Many hosts configure the system to prevent you from doing a chmod by FTP that disables writes. The script Rhea suggests usually works, unless you have a host that disables chmod in PHP! I have a Protection of Configuration contrib (see below) that puts a tool on your admin panel for turning the protection on and off (requires chmod in PHP working.)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...