Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Xsell


Recommended Posts

I get the following message when click on the cross sell link in the admin panel.

NOT FOUND

The requested URL /catalog/admin/FILE_NAME_XSELL_PRODUCTS was not found on this server

 

What am i missing?

I have installed on both the catalog and admin sides and the database.

 

Thanks

Link to comment
Share on other sites

You are missing

define('FILENAME_XSELL_PRODUCTS', 'xsell.php');

in your catalog/admin/includes/filenames.php

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

I wish I knew what to tell you. I have heard there are many people having problems with it but I have it on 2 stores and they both work fine... atleast as far as I can tell.

 

What exactly do you mean "doesn't work"? What isn't working about it?

Edited by wendyjames

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

may i see an example of what it is suppose to look like from one of those sites?

 

What i mean by it doesnt work is exactly that. According to the screen shot it is suppose to place a table with images below the product description. Nothing shows though, not even a table. Everything has been installed exactly like instructed and i get no errors.

Link to comment
Share on other sites

may i see an example of what it is suppose to look like from one of those sites?

 

What i mean by it doesnt work is exactly that. According to the screen shot it is suppose to place a table with images below the product description. Nothing shows though, not even a table. Everything has been installed exactly like instructed and i get no errors.

 

In the admin area or the catelog?

 

One of the sites is for a client and the site is not "live" yet and I can't give out their url. The other site is on my computer... if you give me a little while I can upload what I have now to my space so you can take a look but you will have to remember the site is in process so it isn't beautiful. lol

 

I am going to go upload it now and add the info to the database so I will come back when it is up.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

One thing you could try...

in catalog/product_info.php

 

try changing

<?php

//added for cross -sell

if ( (USE_CACHE == 'true') && !SID) {

echo tep_cache_also_purchased(3600);

include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

} else {

include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

include(DIR_WS_MODULES . FILENAME_ALSO_PURCHASED_PRODUCTS);

}

}

?>

to

<?php

//added for cross -sell

if ( (USE_CACHE == 'true') && !SID) {

echo tep_cache_also_purchased(3600);

include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

} else {

include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

}

}

?>

and see if the box shows up.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

Ok, I have put my site up there are only a couple of products in one category that i have been using for testing so the names are stupid and descriptions are gibberish, layout isn't how it will be in the end and so on... but it will show the xsell box on the bottom of the product description page

 

http://digitalreject.com/store/index.php?c...audio-car-audio

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

Yea mine doesnt do that at all. I have nothing. I only have two contributions to finish and im done this one and another and and both have issues so i am at a stand still.

 

So with that said what contribution did you use to list the products on this page

 

http://digitalreject.com/store/index.php?c...176319d3afbb1fc

 

I have also been looking for something like that

Link to comment
Share on other sites

One thing you could try...

in catalog/product_info.php

 

try changing

<?php

//added for cross -sell

  if ( (USE_CACHE == 'true') && !SID) {

    echo tep_cache_also_purchased(3600);

    include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

  } else {

    include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

      include(DIR_WS_MODULES . FILENAME_ALSO_PURCHASED_PRODUCTS);

    }

  }

?>

to

<?php

//added for cross -sell

  if ( (USE_CACHE == 'true') && !SID) {

    echo tep_cache_also_purchased(3600);

    include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

  } else {

      include(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS);

    }

  }

?>

and see if the box shows up.

 

 

No that didnt work ether, any other ideas? Thier is one line that needed to be inserted into the Database, but that wouldnt keep the table from showing.

Link to comment
Share on other sites

And did you try the suggestion I gave above?

I did find that when I had the include(DIR_WS_MODULES . FILENAME_ALSO_PURCHASED_PRODUCTS); that the xsell didn't show up except if a product had been purchased with other products but when i changed it to nclude(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS); it always showed up.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

I used http://www.oscommerce.com/community/contributions,3123

but i know there are several of these contributions to choose from.

 

for the qty I used

http://www.oscommerce.com/community/contributions,3050

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

No that didnt work ether, any other ideas?  Thier is one line that needed to be inserted into the Database, but that wouldnt keep the table from showing.

 

 

Are you sure? I think the database line is what allows osc to see what products you are assigning to products. Not sure how you could run it without the sql statement thing... if you could they wouldnt tell you to add it to the database.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

And did you try the suggestion I gave above?

I did find that when I had the include(DIR_WS_MODULES . FILENAME_ALSO_PURCHASED_PRODUCTS); that the xsell didn't show up except if a product had been purchased with other products but when i changed it to nclude(DIR_WS_MODULES . FILENAME_XSELL_PRODUCTS); it always showed up.

 

 

Yes i tried it and had no luck. I am out of ideas.

Link to comment
Share on other sites

The SQL file wouldnt keep the actually table from showing . The DB doesnt control tables, just whats shown in them. 2 of the SQLs took, one of them didnt. Like i said though that wouldnt keep the text "We also Recommend" and the table from showing. So its a little deeper then a DB problem. Thats why im clueless since i have gone over the code many times.

 

 

Also one of this links you listed was for a checkbox instead of a qty box.

Link to comment
Share on other sites

woops sorry... i have so many contribs on my computer i forget which ones i used.

 

there is this one

http://www.oscommerce.com/community/contributions,2113

or this one

http://www.oscommerce.com/community/contributions,2147

or

http://www.oscommerce.com/community/contributions,1253

but i think this is the one i used

http://www.oscommerce.com/community/contributions,2040

 

not sure why you wouldnt add the database info, if you dont tell it what to show it wont show anything just like specials

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

No No No, i did run the SQL for all 3 of the included SQL files.

 

This one here:

 

ALTER TABLE products_xsell ADD ID int(10) NOT NULL auto_increment, ADD PRIMARY KEY (ID);

 

came back with errors:

 

#1060 - Duplicate column name 'ID'

 

I understand that the DB querys what to show, i know that. But it doesnt control text and the table. The table and text show at least be showing if it was just a DB issue. Thats why im confused because all the code is perfect and sending no errors. On top of that, that SQL line above is for the admin side and not the catalog side so i should be getting something.

Link to comment
Share on other sites

I believe the contribution only shows if there are items in it, do you have some items set up?

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...