Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

No input file specified error over SSL


bettie_hemlock

Recommended Posts

I had SSL / https connections up and running for login and checkout but just changed my web directory to be simply .com instead of .com/store and now when I try to use an https link I get the error "No input file specified."

 

My images and css are working just fine. I can add to the cart too. Just no joy for logins etc.

 

I have changed my config.php to look like this:

 

  define('HTTP_SERVER', 'http://flesh-press.com'); // eg, http://localhost - should not be empty for productive servers

 define('HTTPS_SERVER', 'https://flesh-press.com'); // eg, https://localhost - should not be empty for productive servers

 define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 define('HTTP_COOKIE_DOMAIN', 'www.flesh-press.com');

 define('HTTPS_COOKIE_DOMAIN', '');

 define('HTTP_COOKIE_PATH', '/cgi');

 define('HTTPS_COOKIE_PATH', '');

 define('DIR_WS_HTTP_CATALOG', '/');

 define('DIR_WS_HTTPS_CATALOG', '/');

 define('DIR_WS_IMAGES', 'images/');

 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

 define('DIR_WS_INCLUDES', 'includes/');

 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');



 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

 define('DIR_FS_CATALOG', '/home/fpress/flesh-press.com/store/');

 

 

I figure there's a change I have missed someplace but I'm not sure where it is. >_< Could someone please point me in the right direction?

 

Thanks!

Link to comment
Share on other sites

define('DIR_FS_CATALOG', '/home/fpress/flesh-press.com/store/');

 

your note:

 

changed my web directory to be simply .com instead of .com/store

 

so fs_catalog is wrong

Link to comment
Share on other sites

define('DIR_FS_CATALOG', '/home/fpress/flesh-press.com/store/');

 

your note:

 

changed my web directory to be simply .com instead of .com/store

 

so fs_catalog is wrong

 

 

I thought that defined the actual directory on the web server, not the URL? I tried changing that and I just got 404 not found for everything...

Link to comment
Share on other sites

I thought that defined the actual directory on the web server, not the URL? I tried changing that and I just got 404 not found for everything...

 

 

Okay, I changed it but I'm still getting the same error. It's easy to reproduce, just click login and the error will be displayed instead of login.php

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...