Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
lizardz

payflow pro problems

Recommended Posts

I'm having trouble getting the payflow pro module working.

 

Site is on a shared server, freebsd 4.8, the sdk stuff is installed, the paths are set, the test.sh successfully puts through the test charge.

 

I've set the path to the executable as: /usr/www/users/ouraccount/pfp/bin

 

does it need the executable too in that path, seems to work fine using that path set in test.sh, order goes through.

 

First problem, which has been posted here without an answer, is that I can't get the test-payflow.verisign.com to go through, it just keeps looping back to the checkout page from confirm order page. No error message, nothing, just loops.

 

We tested it live, submitting a charge to payflow.verisign.com today and the charge appeared to go through, the order was accepted, but the order was not registered in verisign, no charge in the account history.

 

I've tried everything. The partnerid is: wfb, I'm not clear on whether that's what you use for testing, I've tried using partnerid: verisign too and that didn't work.

 

Does anyone have any hints or clues as to what might be wrong?

 

I'm using the same verisign user vendor and user ids, like this:

 

PayflowPro Vendor

sit555444666

 

PayflowPro User

sit555444666

 

which is also what I used in test.sh, and which worked fine.

 

Are there any known issues or bugs that haven't been documented, I've tried searching the forums for a solution but can't find one.

 

We're using osc milestone 1.1 I think, and the milestone 1.1 payflow pro module, with the updates on the module download page.

 

Anybody have any idea, hopefully? Since there's no error output I have no way at all of knowing what's going wrong.

Share this post


Link to post
Share on other sites

I'm new to osC, and have an existing Payflow Pro (*not* Link) gateway in use. I've not been able to find the PFP payment module... if you can point me to it I can get involved in making it work. :)

Edited by Petes

Share this post


Link to post
Share on other sites

The executable MUST be in the path.

 

Mine is:

 

/home3/ur/public_html/cgi-bin/pfpro

 

Notice the name of the executabe (pfpro) without any extension.

 

This payment module is a bear to get working but once working is excellent. Keep with it :)

 

Regards,

 

Donna

Share this post


Link to post
Share on other sites

I'm using Payflow Pro and so far it's working but it took awhile to get worked out.

 

My settings are

 

PayflowPro Library Path

/home/docaf/public_html/cgi-bin/plug-ins/lib

 

PayflowPro Certificate Path

/home/docaf/public_html/cgi-bin/plug-ins/certs

 

PayflowPro Executable

/home/docaf/public_html/cgi-bin/bin/pfpro

Share this post


Link to post
Share on other sites

I believe the problem is one of the following.

 

1) You may be running PHP in safe mode, in which case exec(<pfpro expression>) doesn't work. If this is the case, see if your administrator will disable safe mode, or to at least enable exec to work for one directory, in which case you can put your pfpro.sh file in that directory.

 

2) Also, exec() seems to remove the quotes from the pfpro expression. Somebody needs to re-work the script to escape and unescape the quotation marks in the script.

 

The module should then work properly. I'll get around to doing this sometime soon.

Share this post


Link to post
Share on other sites

I am using payflow pro with Oscommerce, i have integrated well, but when i click on payment link it takes too much time and atlast it gives CGI Error or CGI Time out.???

 

Hope someone cna help me out..??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×