Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem


GordR

Recommended Posts

Hi

 

i have installed my oscommerce system....now when i come to the finalpage on the setup pages and select catlog i get page not found message..

 

Now the address it is trying to go to is this:

 

[ur=http://www.japscene.co.uk/jsonlineshop/catalog/install/://www.japscene.co.uk/jsonlineshop/catalog/index.php]http://www.japscene.co.uk/jsonlineshop/cat...talog/index.php[/rl]

 

Yet you put this address in and it works fine.. yet no images are showing

 

www.japscene.co.uk/jsonlineshop/catalog/index.php.....

 

This problem occurs whenever you go to a dfferent page..... whether its admin or shop front..and one have any ideas??

 

Cheers

 

Gord

Link to comment
Share on other sites

No, you need to copy and paste the code here. You can't link to it.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

ok

 

---------------

 

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', '://'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://japscene.co.uk'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.japscene.co.uk');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', 'www.japscene.co.uk/jsonlineshop/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/jsonlineshop/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/content/StartupHostPlus/j/a/www.japscene.co.uk/web/jsonlineshop/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'mysql.hosts.co.uk'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'onlineshop');

define('DB_SERVER_PASSWORD', 'mazdarx');

define('DB_DATABASE', 'onlineshop1');

define('USE_PCONNECT', 'true'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

 

-----

 

gord

Link to comment
Share on other sites

Replace

 define('DIR_WS_HTTP_CATALOG', 'www.japscene.co.uk/jsonlineshop/catalog/');
define('DIR_WS_HTTPS_CATALOG', '/jsonlineshop/catalog/');

with

 define('DIR_WS_HTTP_CATALOG', 'catalog/');
define('DIR_WS_HTTPS_CATALOG', 'catalog/');

You should also get rid of the www before the HTTP_COOKIE_DOMAIN

 

Jason

Link to comment
Share on other sites

Replace

 define('DIR_WS_HTTP_CATALOG', 'www.japscene.co.uk/jsonlineshop/catalog/');
define('DIR_WS_HTTPS_CATALOG', '/jsonlineshop/catalog/');

with

 define('DIR_WS_HTTP_CATALOG', 'catalog/');
define('DIR_WS_HTTPS_CATALOG', 'catalog/');

 

k mate ill give it ago...one sec

Link to comment
Share on other sites

ermm well

 

the links the site trys to use hve almost 2 address in them..when what you realy need is effectivly the last one...so what i need to do is get rid of the 1st..if yuo get me...for example

 

http://www.japscene.co.uk/jsonlineshop/catalog/admin/ that is the link to get to the admin panel...so then i click on configure on this page and this is the linkit tries to go to...

 

http://www.japscene.co.uk/jsonlineshop/cat...540160bb28bcc81

 

when what the link should be is this..the latter part of the link

 

www.japscene.co.uk/jsonlineshop/catalog/admin/configuration.php?selected_box=configuration&gID=1&osCAdminID=87f13e0fc5cbe2485540160bb28bcc81

 

Hope the explains it a bit better..

 

cheers

 

gord

Link to comment
Share on other sites

This is also wrong

 

define('HTTP_SERVER', '://');

should be

define('HTTP_SERVER', 'https://japscene.co.uk');

unless you took it out to post on here

 

actually looking at the url you posted i am willing to bet that is the problem

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

Below are the correct settings for your catalog/includes/configure.php file. Some of your original settings are for a site with a full ssl certificate. Did you purchase and install one? I have assumed you don't have one and rewritten the file accordingly.

 

Vger

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 [url=http://www.oscommerce.com]http://www.oscommerce.com[/url]

 Copyright ? 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.japscene.co.uk/jsonlineshop'); 
 define('HTTPS_SERVER', ''); // use only if you have a full ssl cert installed, otherwise leave blank for now
 define('ENABLE_SSL', false); // only if you have full or shared ssl, otherwise it's false
 define('HTTP_COOKIE_DOMAIN', 'www.japscene.co.uk'); //this is correct
 define('HTTPS_COOKIE_DOMAIN', '');
 define('HTTP_COOKIE_PATH', '/catalog/');
 define('HTTPS_COOKIE_PATH', '');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/content/StartupHostPlus/j/a/www.japscene.co.uk/web/jsonlineshop/catalog/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'mysql.hosts.co.uk'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'onlineshop');
 define('DB_SERVER_PASSWORD', 'mazdarx');
 define('DB_DATABASE', 'onlineshop1');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

Link to comment
Share on other sites

Cheers Vger...wored a trick... main shop fornt is working nicelty now..

 

BUT!! The admin panel still doesnt work.... i can get onto main page np...but when i clikc to go to say configuration i still get 404 messgae......this is def down to the link.... its odd...as it ilike it is puttin a second addy in fornt of the correct one...

 

Cheers

 

gord

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...