Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can view admin but not Catalog


Guest

Recommended Posts

Hi

 

I am new to OsCommerce and not technical at all. I wanted to try oscommerse outr on my MAc and learn to use it I have loaded it onto my Apple Mac (OSX) and have used the articles posted on this forum to get around the initial error messages etc.

 

I am now in a position where I can now view the amin pages at http://localhost/catalog/admin but I am unable to view the catalog itself. All I get is a blank white page - no error messages - nothing !

I'm puzzled as to why the admin pages are viewable but not the catalog. I have tried several browsers but it is always a blank page.

 

Does anyone have any ideas?

 

Thanks

Link to comment
Share on other sites

Hi

 

Here is my confugure.php file minus the database login info

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://localhost'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'localhost');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/Library/WebServer/Documents/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

Thanks :D

Link to comment
Share on other sites

This IS the file pathway on your Mac to that folder:

 

'/Library/WebServer/Documents/catalog/');

 

This (or similar) is the 'localhost' pathway to that folder:

 

/usr/local/apache/htdocs/catalog/

 

Vger

Link to comment
Share on other sites

Hi

 

Thanks for your reply.

 

Does that mean I have to replace:

 

define('DIR_FS_CATALOG', '/Library/WebServer/Documents/catalog/');

with

define('DIR_FS_CATALOG', '/usr/local/apache/htdocs/catalog/');

 

Is that right? I tried that but it was the same. I did say I wasn't technical !

 

Coin

Link to comment
Share on other sites

Did you edit your index.php or any part index may use - like within the admin tool? I found I got parse errors which caused blank pages when I would make changes from within the admin tool or online from my webhosting tool. The exact same scripting changes would be just fine if I wrote it out in Notepad and uploaded the file that way.

Link to comment
Share on other sites

Are you using the default apache server that comes with Mac OSX or did you install your own. I installed XAMPP for Mac, and the pathway for that is /usr/local/xampp/htdocs/, but using the default apache install it may just read /usr/local/htdocs?

 

What does the pathway say in admin/includes/configure.php?

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...