Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

error message


silverwraith

Recommended Posts

Hi,

 

I just installed osCommerce through the Fantastico module in my cpanel and none of the images were showing up so I edited the config file in includes and now the images work, but I'm getting this error message:

 

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/mydomain/public_html/mysubdomain/order/includes/configure.php:46) in /home/mydomain/public_html/mysubdomain/order/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/mydomain/public_html/mysubdomain/order/includes/configure.php:46) in /home/mydomain/public_html/mysubdomain/order/includes/functions/sessions.php on line 67

 

 

I've tried everything I can think of. I know it's probably something ridiculously simple, but it's Sunday morning and lack of sleep and too much coffee are conspiring against me. lol

 

Please help before I lose what little I have left of mind :blink:

 

Thanks,

Kay

Link to comment
Share on other sites

Just do a quik reinstall and select your sessions to be stored on database, your errors should go away...

Link to comment
Share on other sites

Just do a quik reinstall and select your sessions to be stored on database, your errors should go away...

 

 

Fantastico is an autoinstaller set up by my hosting company and it doesn't give you the option of choosing. This is a fresh install and if I reinstall it will just be the same thing.

 

Any other ideas?

Link to comment
Share on other sites

go back to your config file and find this line at the bottom and make it read this:

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

Link to comment
Share on other sites

go back to your config file and find this line at the bottom and make it read this:

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

 

 

Thanks for responding! I checked and it already does :'( This is mine:

 

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

Any other ideas? I am completely at a loss. I've tried everything I can think of. :sweating:

 

Thank You,

 

Kay

Link to comment
Share on other sites

Try the following knowledge base article on

 

/home/mydomain/public_html/mysubdomain/order/includes/configure.php

 

http://www.oscommerce.info/kb/osCommerce_D...mon_Problems/15

 

HTH

Tom

 

 

The cache is already set on false so I'm going to wade through the post that OceanRanch recommended and see if it helps. :thumbsup:

 

Thank You both very much for your input!

 

Kay

Link to comment
Share on other sites

The cache is already set on false so I'm going to wade through the post that OceanRanch recommended and see if it helps. :thumbsup:

 

Thank You both very much for your input!

 

Kay

 

 

IT WORKED!

 

This thing has been driving me insane all day and it was so simple. Thank You so much for taking the time to point me in the right direction, Tom! I really appreciate it.

 

Have a great day,

 

Kay

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...