Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Who can help me


super2000

Recommended Posts

I get these messages,

 

Warning: main(includes/configure.php): failed to open stream: Permission denied in /home/httpd/vhosts/super2000.com/httpdocs/catalog/includes/application_top.php on line 29

 

Fatal error: main(): Failed opening required 'includes/configure.php' (include_path='.:/usr/share/pear') in /home/httpd/vhosts/super2000.com/httpdocs/catalog/includes/application_top.php on line 29

 

In what Folder of File do I look to find this and what do I do to correct it.

 

An other thing, I was supposed to delete the directory "Install" or rename it, it wont let me delete it as the directory is not empty. Should I just rename it?

 

I am very new to php and mysql and I hope you be patient with me.

 

Thank you.

Link to comment
Share on other sites

I get these messages,

 

Warning: main(includes/configure.php): failed to open stream: Permission denied in /home/httpd/vhosts/super2000.com/httpdocs/catalog/includes/application_top.php on line 29

 

Fatal error: main(): Failed opening required 'includes/configure.php' (include_path='.:/usr/share/pear') in /home/httpd/vhosts/super2000.com/httpdocs/catalog/includes/application_top.php on line 29

 

In what Folder of File do I look to find this and what do I do to correct it.

 

An other thing, I was supposed to delete the directory "Install" or rename it, it wont let me delete it as the directory is not empty. Should I just rename it?

 

I am very new to php and mysql and I hope you be patient with me.

 

Thank you.

Link to comment
Share on other sites

 

 

I quess I reply to myself for the time being. May be somebody can look at it and tell me if I am on the right track.

 

I found the first part of my question

the home/httpd/vhosts/super2000.com/

is the first view in ftp_pro

than I click on

httpdocs/catalog/includes/

and find the file

application_top.php

I view the file in Notepad and on line 29 I find this statement:

 

(DIR_WS_FUNCTIONS . 'database.php');

 

// make a connection to the database... now

tep_db_connect() or die('Unable to connect to database server!');

 

Question! Is this the error I get? and how do I correct it!

I thought I set up the database in the first view steps of installation?

Link to comment
Share on other sites

1.Try setting permissions to 777 on configure.php

2.As above

 

Alternate answers

 

1. Make sure the defines in configure.php are correct, and your db host, username, password etc.

2. Snap

 

I downloaded a phpEditor and viewed the file in the editor application_top.php and line 29 was

 

require('includes/configure.php');

 

and not as previously stated.

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', ''); I took the username out

define('DB_SERVER_PASSWORD', ''); and also the password just for this example

define('DB_DATABASE', 'Products');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

 

Is there supposed to be something else beside 'localhost'?

 

I am not very smart, ha, but did all my websites on FrontPage for a number of years and once you get used to it it's hard to change.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...