Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

1046 - No Database Selected


Guest

Recommended Posts

Hello,

 

I installed and was running osCommerce 2-2ms2 on Windows 2k, using WAMP5 - a bundle of Apache 1.3.33(Win32), PHP 4.3.10, MySQL 4.1.8 and PHPmyadmin 2.6.0pl-3. Everything was working fine - and I was beginning to modify the appearance of the store. Then I copied the remote version to my local machine, as I'd made some changes and wanted to keep up to date - and ran into problems.

 

I deleted and reinstalled WAMP5, and then added the catalog folder to the webroot - but when I went to start the installation (having switched register_globals on) I keep getting the following message:

 

"1046 - No database selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]"

 

Therefore I can't run the installation - in spite of deleting and reinstalling. Can anyone tell me what I've done wrong - or how to get round it? Any advice gratefully received!

Link to comment
Share on other sites

If you reinstalled your web server then you'll need to go to phpMyAdmin and set up a new blank database for the install to import the contents of install/oscommerce.sql into.

 

Vger

Link to comment
Share on other sites

If you reinstalled your web server then you'll need to go to phpMyAdmin and set up a new blank database for the install to import the contents of install/oscommerce.sql into.

 

Vger

 

Thanks Vger! That's sorted it. I think I was going round in circles for too long! :thumbsup:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...