Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

images arnt showing


Guest

Recommended Posts

ok when i login to the admin panel it says : Catalog images directory does not exist: /usr/local/customer/virtualfp/secure/images/

 

ive looked and there is a folder called images in the root - although where it gets that ^ url from i have no idea.

 

when i add a product and browse to a picture it doesnt upload it or anything.

 

anyone know whats going on please?

Link to comment
Share on other sites

heres my config.php file if it helps

  define('HTTP_SERVER', 'http://www.mywebspace.co.uk'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://secure18.easyspace.com/www.mywebspace.co.uk'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', 'true'); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'http://www.mywebspace.co.uk/');
 define('HTTPS_COOKIE_DOMAIN', 'http://www.mywebspace.co.uk/');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

Link to comment
Share on other sites

I'm going to ask the obvious - - did you try creating your directory structure to match oscommerce?

 

Otherwise, you'll need to wait for one of the pros to come along and tell you where to change the pointer. OScommerce is looking for that url because one of the files says that's where images are stored. When you change the php file that points to the image directory and point it instead to YOUR url, the images will appear.

Link to comment
Share on other sites

also it gives an error on the products page (admin)

 

Error: Catalog images directory does not exist: /usr/local/customer/virtualfp/secure/images/

Link to comment
Share on other sites

/secure/images/

 

This points to a seperate 'secure' folder for https pages - so you'll have to upload a complete copy of all files and folders to the 'secure' folder.

 

See you ignored it when I pointed out to you that using a web url in your signature is against forum rules and seen as self-promotion.

 

Vger

Link to comment
Share on other sites

ok progress. seems everything is fine when i configure the admin config.php NOT using my secure server urls.

 

so................dunno what to do now hehe

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...