Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Permission Settings


DVDMadMan

Recommended Posts

I have just finished installing the software and now doing the final settings.

 

On the test site, its giving me 2 warnings the first is that the CATALOG/INCLUDES/CONFIGURE.PHP file is still writable, need to change the permission to 444,

 

But when i change this and refresh the site, it resets the file to 644.

 

Has anyone got an idea how to do this???

 

the 2nd problem is that there is no TMP directory, but where do i create this??

 

I have created a TMP directory in 4 different places and still this doesnt seem to be the right place for the software.

 

Cheers in advance

Link to comment
Share on other sites

The permissions can be changed via your control panel (make it read only) or via a ftp client using the chmod 400 configure.php command.

 

If this doesn't work then check with your host, he probably doesn't allow permission changes and will have to do it for you.

 

Second problem on /tmp. The directory that is defined via your osc admin panel in sessions needs to be somewhere in your web space and fully read/writable or "chmod 777".

 

Or you can store sessions in your database by changing the TWO configure.php files at the bottom of each file.

 

catalog/includes/configure.php

catalog/admin/includes/configure.php

 

define('STORE_SESSIONS', 'mysql');

 

HTH

Tom

Link to comment
Share on other sites

The permissions can be changed via your control panel (make it read only) or via a ftp client using the chmod 400 configure.php command.

 

If this doesn't work then check with your host, he probably doesn't allow permission changes and will have to do it for you.

 

Second problem on /tmp. The directory that is defined via your osc admin panel in sessions needs to be somewhere in your web space and fully read/writable or "chmod 777".

 

Or you can store sessions in your database by changing the TWO configure.php files at the bottom of each file.

 

catalog/includes/configure.php

catalog/admin/includes/configure.php

 

define('STORE_SESSIONS', 'mysql');

 

HTH

Tom

 

I have tried both of these, and im still having the same problems, ive tried editing the error message setting in the Application_top.php file, but this doesnt seem to change anything either.

 

Can anyone tell me what the correct section is to edit on the Application_top.PHP files.

 

Cheers

Link to comment
Share on other sites

dont edit application_top.php, your file will still be writeable. if you still get the message and your host will not set the permissions, then it is time to change hosts, as your files are / most likely will be hacked.

Link to comment
Share on other sites

dont edit application_top.php, your file will still be writeable.  if you still get the message and your host will not set the permissions, then it is time to change hosts, as your files are / most likely will be hacked.

 

Cheers this will be the 3rd host that ive been with cause of similar problems.

Link to comment
Share on other sites

Create a new .txt file on your computer, select 'Save As' and save it as "chmod.php" with the double inverted commas. This will create a .php file.

 

In the file put the following code:

<? php

chmod("/includes/configure.php", 0400);

?>

 

Then upload this file to the root of your website, and put this into your browser http://www.yourdomain.com/chmod.php

 

This will change the permission on the file to 0400 (Owner - Read Only).

 

Vger

Link to comment
Share on other sites

Create a new .txt file on your computer, select 'Save As' and save it as "chmod.php" with the double inverted commas.  This will create a .php file.

 

In the file put the following code:

<? php

chmod("/includes/configure.php", 0400);

?>

 

Then upload this file to the root of your website, and put this into your browser http://www.yourdomain.com/chmod.php

 

This will change the permission on the file to 0400 (Owner - Read Only).

 

Vger

 

Cheers i have sorted it now. but now im getting a problem with the PHP.INI file. but as yet im unable to find this, and im not sure what code i need to add or remove to allow me to upload files.

 

Can any one help??

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...