Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

stuck at step install part 2


voigtstr

Recommended Posts

http://<my address>/catalog/install/install.php?step=2

 

I get the two checkboxes for import catalog database and automatic configuration, but when I hit continue it just goes back to the same page.

 

If I untick the boxes and hit continue, it returns to the same page but with the checkboxes ticked.

 

What am I doing wrong.

 

The only change I have made to oscommerce so far is the patch to no longer require register_globals.

 

Cheers

Simon

Link to comment
Share on other sites

I just had this problem, a quick search for step2 in this forum gave some options.

 

I first installed pear, run the go-pear.bat file in your php directory. Then restarted my apache server...This didn't help.

 

I then enabled register_long_arrays in my php.ini, restarted the apache server and the install started working.

 

Try enabling register_long_arrays first, then if that doesn't work install pear.

 

 

http://<my address>/catalog/install/install.php?step=2

 

I get the two checkboxes for import catalog database and automatic configuration, but when I hit continue it just goes back to the same page.

 

If I untick the boxes and hit continue, it returns to the same page but with the checkboxes ticked.

 

What am I doing wrong.

 

The only change I have made to oscommerce so far is the patch to no longer require register_globals.

 

Cheers

Simon

Link to comment
Share on other sites

I just had this problem, a quick search for step2 in this forum gave some options.

 

I first installed pear, run the go-pear.bat file in your php directory. Then restarted my apache server...This didn't help.

 

I then enabled register_long_arrays in my php.ini, restarted the apache server and the install started working.

 

Try enabling register_long_arrays first, then if that doesn't work install pear.

 

Thank you for your assistance so far.

 

I now have

register_long_arrays = On [Performance]

in php.ini

 

I installed pear.

 

still stuck at step 2.

phpmyadmin can talk to mysql fine, I wonder why step2 cant connect..

 

ok checking apache error logs shows this

(i've xx'd my address)

 

[client xx.x.xxx.xxx] PHP Warning: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\\Program Files\\Apache Group\\Apache2\\htdocs\\catalog\\includes\\functions\\database.php on line 19

 

How do I correct that one?

Link to comment
Share on other sites

Thank you for your assistance so far.

 

I now have

register_long_arrays = On    [Performance]

in php.ini

 

I installed pear.

 

still stuck at step 2.

phpmyadmin can talk to mysql fine, I wonder why step2 cant connect..

 

ok checking apache error logs shows this

(i've xx'd my address)

 

[client xx.x.xxx.xxx] PHP Warning:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\\Program Files\\Apache Group\\Apache2\\htdocs\\catalog\\includes\\functions\\database.php on line 19

 

How do I correct that one?

 

I've added an ODBC user at localhost using phpmyadmin..(which is probably a security problem) I no longer get the error message in the appache error.log but oscommerce is still getting stuck at step2

Link to comment
Share on other sites

I've added an ODBC user at localhost using phpmyadmin..(which is probably a security problem) I no longer get the error message in the appache error.log but oscommerce is still getting stuck at step2

 

should I reinstall apache, php mysql, oscommerce and start again from scratch?

I'm running on xp pro sp2

 

apache_2.0.54

php-5.0.4

mysql-41.11

myODBC-3.51.11.1

oscommerce-2.2ms2

 

the version of php has global variables depracated, so I'm using the instructions

in REGISTER GLOBALS - V 1.3 - Richard Bentley 13/01/2005

 

Anything else I need to follow? (is there an oscommerce for dummies somewhere?)

Should I use an earlier version of php?

 

Cheers

Simon

Link to comment
Share on other sites

I am having same problem I added the new line for long variables and still no luck can any one help????

 

 

I am so excited to try this and so discouraged I can`t get it to work is there a way to install without the web assistance. meaning manually.

Link to comment
Share on other sites

should I reinstall apache, php mysql, oscommerce and start again from scratch?

I'm running on xp pro sp2

 

apache_2.0.54

php-5.0.4

mysql-41.11

myODBC-3.51.11.1

oscommerce-2.2ms2

 

the version of php has global variables depracated, so I'm using the instructions

in REGISTER GLOBALS - V 1.3 - Richard Bentley 13/01/2005

 

Anything else I need to follow? (is there an oscommerce for dummies somewhere?)

Should I use an earlier version of php?

 

Cheers

Simon

 

Are people using the same versions as above on winxp? should I use older versions of php? should I use the cgi version rather than the dll version?

Link to comment
Share on other sites

Are people using the same versions as above on winxp? should I use older versions of php? should I use the cgi version rather than the dll version?

 

 

Hello I have isntalled the os commerece on my win xp sp 2 machine and had no problems I also for the php software used easy php installed on my system it is running great

 

I am still havving some toruble with the linux box but will post if I figure it out

.

Link to comment
Share on other sites

  • 2 weeks later...

I also had the same problem -- stuck on Step 2.

 

I just changed register_long_arrays = On, restarted Apache, and now it works.

 

(I'm on WinXP, PHP 5, Apache 2, MySQL 4.1)

 

Seems to me the next version should be written to work with the default PHP.ini settings... 'register_globals' is turned off due to a perceived security threat and 'register_long_arrays' is turned off for performance. And what if your web host doesn't have these turned on in their php.ini?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...