Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

any pages in admin directroy are BLANK


warrenp

Recommended Posts

Any page I try to view in the admin directory comes up blank... (I.e index.php)

 

Here is my config.php from admin/includes

 

 

 

 

<?php

/*

$Id: configure.php,v 1.14 2003/02/21 16:55:24 dgw_ Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

 

// define our webserver variables

// FS = Filesystem (physical)

// WS = Webserver (virtual)

define('HTTP_SERVER', 'http://localhost'); // eg, http://localhost or - https://localhost should not be NULL for productive servers

define('HTTP_CATALOG_SERVER', '');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

define('DIR_WS_ADMIN', '/catalog/admin/');

define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);

define('DIR_WS_CATALOG', '/catalog/');

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', 'root');

define('DB_SERVER_PASSWORD', 'password');

define('DB_DATABASE', 'oscommerce');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

Any ideas?

Link to comment
Share on other sites

You have possibly overwritten index.php with its corresponding language file - this will display a blank page without error :P

 

Matti

Link to comment
Share on other sites

You have possibly overwritten index.php with its corresponding language file - this will display a blank page without error  :P

 

Matti

 

Thanks Matti,

I replaced the index.php in the admin file with the one from the orignal downloaded zipped folder but no change. It isn't just index.php, but ALL php's in the admin folder. Including the easypopulate.php I've just put in there.

 

hmmmm. Could I put up any other config files here so people could see any errors?

Link to comment
Share on other sites

If I rename the admin/includes folder to something else and then paste in the includes folder from the catalog directory, then the php files work (at least easypopulate does).

 

However it is not the includes/configure.php file that is the problem (at least not alone), because if I rename and replace just this file, it still doesn't work.

 

So the question now is (it would seem to me). What other files in the includes directory (and/or subfolders) are pivotal in allowing php files in the admin directory to execute?

 

I could rename paste each one individually until I find the culpirt, but I'm hoping someone here might have a quicker idea!

 

Many thanks

warren

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...