Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

*Endless* loop of index and login pages


elodea

Recommended Posts

One of my customers (new) just sent me a page long email saying she had to sign up in order to browse the site and it's shady cause no matter what she does it only let her loop from index to login pages. She told me if she's the first one complaining that's because either she's the most annoyed or people cannot even go to 'contact us' page without signup.

 

I tested my site twice, one with existing account, another by signing up new id. Both seems to work flawless, but looking up her records, she did just loop from login and index pages and she has logged on six times.. She mentioned that she sees the greeting by name but had to log in again and again.

 

If you don't mind can you please take a look at my site and see if it's 'shady' in a way that you cannot even browse??? If you don't mind, can you just take a second to go to my site and click couple of links to see if signup is necessary? Moripin.com is my site, and any help will be great. Because I cannot replicate the behavior, I really don't know where to start to look at even.

 

Thank you very much!

Link to comment
Share on other sites

Nice site! Love the color scheme...I didn't have any problem at all browsing with IE or Firefox. Maybe it was some setting on her computer?

 

 

Thanks for helping and your kind comment!! But it would be useless if customers cannot browse :'(

 

I checked my visitors stat, and saw at least five people who visited login pages number of times in a rows, or stays within login/creataccount/passwordforgotten pages.. But the weird thing is I also see people who were able to browse.

 

weird weird.. :(

Link to comment
Share on other sites

Your cookie domain setting and/or cookie path is incorrect. You haven't noticed that the session ID is persistent in the URL? That should go away (and be pulled from cookie) after the first click.

 

BTW, nice SEO URLs :)

 

Bobby

Link to comment
Share on other sites

Your cookie domain setting and/or cookie path is incorrect.  You haven't noticed that the session ID is persistent in the URL?  That should go away (and be pulled from cookie) after the first click.

 

BTW, nice SEO URLs :)

 

Bobby

 

 

Bobby, thank you very much but can you be nice enough to explain more?

I do not use cookie right now, at least that's what I think I am doing, and don't know what to do.. I am not making use of the cookies 'cuz I personally cannot browse if the cookies are on in my computer. (for the same reason I hardly go to bestbuy homepage..)

 

And, double 'thank you for all your great contributions! They were all easy to follow!

Link to comment
Share on other sites

 

Bobby, thanx! I changed this

 

  define('HTTP_SERVER', 'http://moripin.com'); 
 define('HTTPS_SERVER', 'https://moripin.com'); 
 define('ENABLE_SSL', true); 
 define('HTTP_COOKIE_DOMAIN', 'moripin.com');
 define('HTTPS_COOKIE_DOMAIN', 'moripin.com');
 define('HTTP_COOKIE_PATH', '/home/myid/moripin.com/cgi');
 define('HTTPS_COOKIE_PATH', '/home/myid/moripin.com/cgi');

 

to this

 

  define('HTTP_SERVER', 'http://moripin.com'); 
 define('HTTPS_SERVER', 'https://moripin.com'); 
 define('ENABLE_SSL', true); 
 define('HTTP_COOKIE_DOMAIN', '.moripin.com');
 define('HTTPS_COOKIE_DOMAIN', '.moripin.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');

 

and I have no more annoying oscid..

 

But, was it the one causing the signin problem? or just something you noticed to be removed?

Link to comment
Share on other sites

Apparently the issue was in the COOKIE_PATH setting...it could NOT POSSIBLY use that setting and would present problems like you report. The previous COOKIE_DOMAIN setting was not too far off and should have worked.

 

I'm about 98.21% (+/- 0.02%) sure that is the root cause of your login issue.

 

Bobby

Link to comment
Share on other sites

Apparently the issue was in the COOKIE_PATH setting...it could NOT POSSIBLY use that setting and would present problems like you report.  The previous COOKIE_DOMAIN setting was not too far off and should have worked.

 

I'm about 98.21% (+/- 0.02%) sure that is the root cause of your login issue.

 

Bobby

 

 

Thank you! I can sleep tonight now!! :P

 

and the statistics. that's more than two sigma! yay!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...