Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Permissions configuration after manual configure?


Recommended Posts



Well its taken me about 24 hours to finally get this thing installed... sigh..


After trying the automatic installation on a variety of Apache versions I finally went back to Foxserv and installed osC manually...


Almost there woohoo... but I get the following warning at the top of the main catalog page.



Warning: I am able to write to the configuration file: C:/FoxServ/www/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.




I've looked at the forum.. and everyone seems to be saying set permisions to 777 or 444... :( So my question is this.. in the configuration file, what exactly do I write, or what exactly do I change to alter permissions...


Any advice appreciated..



(Some day I'll start designing the site... :blush: )


By the way.. if anyone ever asks how to fix an automatic installation step3 problem... where it says the oscommerce.sql file doesn't exist.. tell them to install manually...might save them some time...

Link to comment
Share on other sites

Either via your cpanel or via ftp set the permissions to Read Access only.


Normally you can just go to the configure.php via the cpanel and right click and choose security or permissions and set them to Read Only (444 is fine if they give you that choice.)


Or you can use your ftp program to go to that file (cd .....) and set permissions using the "chmod 444 configure.php" command.


Some hosts do not allow you to change "permissions" so if you can't then you might have to contact them.


BTW 444 (Read only for everybody)

777 (Read/Write/Execute) for everbody.




Link to comment
Share on other sites



I'm actually developing on a local machine at the moment... so I guess that if I leave the permissions as they are.. get the site working locally... then I can worry about setting permissions to access the configuration.php file at a later date.


On thing though on my local machine.. I guess I would use command prompt to chmod the file... (thats either a really obvious or a really stupid thing to have said I think!!) :) anyway thanks for the advice....


Have a nice night/day all ;)



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...