Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

What Does This Mean


Recommended Posts

At step 7 of installation I keep getting the error message below.


I am working under windows so have tried renaming the configure.php files but then it comes up with a list of error messages and tells me that installation was complete. but when I try to click on catalog or admin buttons it gives me more error messages.


Please tell this stupid novice in simple words what I need to do to get OS working.




The configuration files do not exist, or permission levels are not set.


Please perform the following actions:

cd /usr/home/raptoruk/public_html/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /usr/home/raptoruk/public_html/catalog/admin/includes/

touch configure.php

chmod 706 configure.php


If chmod 706 does not work, please try chmod 777.


If you are running this installation procedure under a Microsoft Windows environment, try renaming the existing configuration file so a new file can be created.

Link to comment
Share on other sites

HI Matt,


I've not seen this specific error before, mostly because I've never been able to get the automatic configuration script to go beyond step 2 - it usually loops! Instead I just do it manually:


1. Copy all the files in the \catalog\ folder to a public published location on the web server

2. Copy all the files in the \admin\ folder to a secured published location (no Anonymous access) on the web server

2. Add the osCommerce database schema to MySQL.

3. Add a user to the MySQL database.

4. Give the new MySQL user privileges to select, update, insert, & delete on the OSCommerce db.

5. Add the MYSQL database info to the bottom of the includes/configure.php on the /catalog/ and /admin/ folders.

6. Set the server values in the includes/configure.php for both /catalog/ and /admin/.

7. Enter the /admin/ side and configure as required.


As to your specific issue, it looks like a permissions thing.


As you are running the configure script through the web-server it will run with the permissions of the Anonymous Internet User (MACHINE_NAME\IUSR_MACHINE_NAME).


This user is unlikely to have write/modify/create privileges for the folders where the configure.php scripts live.


The easiest way in IIS to solve this is to prevent Anonymous Logins to the /install/ folder.


** Instructions for IIS 6 **

In the IIS Manager Console, select your web-site then choose the /install/ folder, right-click the folder, then choose Properties.

Select the "Directory Security" tab.

In the "Authentication and access control" group press the "Edit..." button.

Untick "Enable anonymous access".

Tick "Integrated Windows authentication"

Press the "OK" button to save these settings, and press any further "OK" buttons to close out of these dialogs.


Now access the install folder again (e.g http://localhost/install/) and you should be prompted for a username and password. Give credentials that have modify/write/create privileges for the /install/ folder (usually a server Admin or regular member of the User group will suffice).


Now the auto-configure scripts will run with this user's credentials, and any files that need to be modified/written should succeed*.


* This assumes that all the folders/file needing to be updated have modify/write/create privileges for the user account.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...