Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Accessing Admin Panel


Kevin Scott

Recommended Posts

Hi everyone,

 

I've been doing a search here but can't find anything related.

 

I keep getting this error when trying to get into the admin panel:

 

1046 - No Database Selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

I set my database up correctly but since I'm new to PHP, I must've

done something wrong.

 

The URL I am trying to access is mysite /catalog/admin

 

 

Any Suggestions?

 

 

Kevin "Switching From Agora To OS is a good thing" Scott B)

Link to comment
Share on other sites

Hi everyone,

 

I've been doing a search here but can't find anything related.

 

I keep  getting this error  when trying to get into the admin panel:

 

1046 - No Database Selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

I set my database up correctly but since I'm new to  PHP, I must've

done something wrong.

 

The URL I am trying to access is mysite /catalog/admin

Any Suggestions?

Kevin "Switching From Agora To OS is a good thing" Scott  B)

 

very probably your admin/includes/configure.php is not set up right - you may need to post it here for comment

 

Charles

 

put in dummy values in the bootm bit where your database connection strings are

A kite flies highest AGAINST the wind !

 

"Life should NOT be a journey to the grave with the intention of arriving safely in an attractive and well preserved body, but rather to skid in sideways, a lover in one hand, martini in the other, body thoroughly used up, totally worn out and screaming ~ WOO HOO!! What a ride!"

Link to comment
Share on other sites

very probably your admin/includes/configure.php is not set up right - you may need to post it here for comment

 

Charles

 

put in dummy values in the bootm bit where your database connection strings are

 

 

 

Thanks Charles!

 

Here it is:

 

<?php

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.daguystore.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.daguystore.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/kevscott/public_html/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'none');

define('DB_SERVER_PASSWORD', 'noidea');

define('DB_DATABASE', 'ddd');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

 

I think I'll just try a reinstall but if anyone knows what my problem is, please post.

 

Thanks Again Charles!

 

Kevin

Link to comment
Share on other sites

Looks like you posted your catalog configure.php not your admin configure.php as Charles requested.

 

They are different

 

catalog/includes/configure.php

catalog/admin/includes/configure.php

 

Check the database setting in the admin one.

 

Tom

Link to comment
Share on other sites

  • 4 weeks later...
<?php

 define('HTTP_SERVER', 'http://mysite.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://mysite.com/catalog');
 define('HTTPS_CATALOG_SERVER', 'https://hostxxx.ipowerweb.com/~mysite');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/mysite/public_html/catalog/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/mysite/public_html/catalog/admin/'); // absolute pate required
 define('DIR_WS_CATALOG', '/catalog/'); // absolute path required
 define('DIR_FS_CATALOG', '/home/mysite/public_html/catalog/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'mysite_user');
 define('DB_SERVER_PASSWORD', 'xxxxxxxxxx');
 define('DB_DATABASE', 'mysite_encript');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

Link to comment
Share on other sites

Hi Jodie,

 

Can you tell us what error message you are receiving? And what you were running/step you were in.

 

Which configure.php are you posting?

 

Also if you have a URL that you can post.

 

Tom

Link to comment
Share on other sites

this is the admin configure.php

 

 

Parse error: parse error, unexpected $, expecting T_VARIABLE or '$' in /home/mysite/public_html/catalog/admin/includes/functions/general.php on line 1224

 

the thing is I have this runing localy and works perfect so i know there isnt a parse error.

 

j.

sorry i dont hace a URL

Link to comment
Share on other sites

I can't tell what's exactly at line 1224 of your file, but it appears that it is the ZONES area of admin. (tax zones or zones) Maybe you don't have any setup on the new store. Also, are the versions of PHP the same on both sites?

 

Tom

Link to comment
Share on other sites

configure.php isnt that long of a file.

you do have an error with document root tho,

define('DIR_FS_DOCUMENT_ROOT', '/home/mysite/public_html/catalog/'); // where the pages are located on the server

should be

define('DIR_FS_DOCUMENT_ROOT', '/home/mysite/public_html); // where the pages are located on the server

or

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where the pages are located on the server

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...