Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SQL file does not exist: /install/oscomerce.sql


Guest

Recommended Posts

This one has me baffled. I?m trying a new installation on the machine right here in front of me. It?s a 2003 server running MySQL 4.1.10 using IIS 6 and PHP 4,3,11. I?m running the install and it creates the database and then when is gets to the next screen it gives me this message

 

?SQL file does not exist: /install/oscommerce.sql?

 

Which strikes me as kind of odd since I can look down the directory path and see the file in question. Of course it gives the path as ?/install/oscommerce.sql? and I?m assuming that that means the same thing as ?c:\inetpub\wwwroot\home\catalog\install\oscommerce.sql? (?home? is the folder for the website under wwwroot)

 

Anyone have any clue as to why I see the file and osCommerce doesn?t see the file?

Link to comment
Share on other sites

No (well, I don't)

 

You can however run the .sql file manually in phpmyadmin (or some other mysql front)

Forum search

Contributions search

Documentation search (note: docs being adapted for MS3, may be different for MS2)

3 tips for better forum searching

 

Want to post? Read this first:

osCommerce for dummies

Topic name etiquette

 

Basics:

Basics for design

Right syntax to use near '-20, 20'

Cannot re-assign $this

Parse error

Link to comment
Share on other sites

OK I have progressed a little further with this install I installed PHPmyadmin and ran the sql statement in the ?oscommerce.sql? file. That worked just fine. It created a brand new set of tables in my database and gave me a ?sql query completed successfully? notice. However, osCommerce doesn?t know that. It just keeps taking me back to the error telling me it can?t see the file ?oscommerce.sql? so I just stepped it through to the next page in the install and picked it up from there. This appeared to work OK and ran to completion it seems or something approaching completion. I am now at the next array of errors. It seems I am having trouble with the file ?install_7.php?

 

Here is the output:

 

New Installation

osCommerce Configuration

 

Warning: fopen(/wwwroot/home.local/includes/configure.php): failed to open stream: No such file or directory in C:\Inetpub\wwwroot\home.local\catalog\install\templates\pages\install_7.php on line 209

 

Warning: fputs(): supplied argument is not a valid stream resource in C:\Inetpub\wwwroot\home.local\catalog\install\templates\pages\install_7.php on line 210

 

Warning: fclose(): supplied argument is not a valid stream resource in C:\Inetpub\wwwroot\home.local\catalog\install\templates\pages\install_7.php on line 211

 

Warning: fopen(/wwwroot/home.local/admin/includes/configure.php): failed to open stream: No such file or directory in C:\Inetpub\wwwroot\home.local\catalog\install\templates\pages\install_7.php on line 259

 

Warning: fputs(): supplied argument is not a valid stream resource in C:\Inetpub\wwwroot\home.local\catalog\install\templates\pages\install_7.php on line 260

 

Warning: fclose(): supplied argument is not a valid stream resource in C:\Inetpub\wwwroot\home.local\catalog\install\templates\pages\install_7.php on line 261

 

The configuration was successful!

 

 

Looking at the first error listed here it is giving the location as:

 

C:\Inetpub\wwwroot\home.local\catalog\install\templates\pages\install_7.php on line 209

And when I look in that file on line 209 I see:

 

$fp = fopen($dir_fs_document_root . 'includes/configure.php', 'w');

 

So I?m trying to figure out what it is that it?s looking for and where ?$dir_fs_document_root? is defined or assigned a value. This whole string of errors appear to be related so if I could figure out what it?s referencing or looking for I think I could straighten it out.

 

Any body have any experience with this?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...