Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HTTPS but no Padlock


cclayton

Recommended Posts

Anyone know why my site when it switches from HTTP to HTTPS does not show the padlock but does show HTTPS and when I click on FILE and PROPERTIES it shows as being on SSL.

 

The site is www.creativedestinationseurope.com/tour/

 

Any ideas? Thanks

Founder & Director at CSC Tours Ltd

Link to comment
Share on other sites

Oh, yeah. That's frustrating isn't it! There are several possible causes. In my case it was an issue of how OSC asks your host's server to make it ssl. It's been a while, but in my case it had to be true or false versus 1 or 0; in the config file I think. Then it worked fine. If that doesn't work for you, search the forum. This has been covered many times.

Link to comment
Share on other sites

On checking your site it looks like you might have solved your padlock problem. In my case it's normally the path to he images and buttons not being set to https. For one server I had to change line 40 in application_top.php from:

 

$request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

 

to:

 

$request_type = (getenv('HTTPS') == 1) ? 'SSL' : 'NONSSL';

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...