Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Categories not deleting


Guest

Recommended Posts

Hi. I deleted a couple of categories in the Admin section while the products were still in them. The name of the categories stay in the Category box as well as the subcategories, but when I click on the subcategory (even though it says that there are products in them), it states: "There are no products to list in this category." in the main content section.

 

I checked in phpMyAdmin to see if indeed the products are there, and they are not. PhpMyAdmin also does not list the categories. I want it so that the Categories and Subcategories do not show in the Categories box. How do I get rid of them once and for all? We are about to add our products and make the store live but I cannot with this bug.

 

Any and all suggestions welcomed. Thanks!

Link to comment
Share on other sites

very silly idea

 

Press F5 or click refresh ?

 

i have had these sort of things happen to me and a refresh sorted it

 

That would be an ideal solution! I tried that but it does not work... then I deleted my cookies, and hit refresh, still did not work. I tried new browser, that worked! BUT, when I click on a category, the old categories appear again. This on both IE and Netscape and Firefox.

 

Thanks for your suggestion.... any other thoughts please? :rolleyes:

Link to comment
Share on other sites

That would be an ideal solution! I tried that but it does not work... then I deleted my cookies, and hit refresh, still did not work. I tried new browser, that worked! BUT, when I click on a category, the old categories appear again. This on both IE and Netscape and Firefox.

 

Thanks for your suggestion.... any other thoughts please?  :rolleyes:

 

 

Hi! admin panel catalog/ categories/products click on category then delete. It will tell you if there are any items in the child level, but will ultimately remove them with the category heading from your list.

We help each other, to help ourselves!

Aloha Allison!

 

Liken to wrinkles, the many paths of my life not only altered my destiny, but my appearance.

 

Poetry, the artistry of plying ones soul to the empty canvases of life. A vision without sight. A verse without darkness. Lighting each day with a prose of beauty and love.

Link to comment
Share on other sites

Thanks for your suggestions... The problem is that the category or products in question is not showing up in the admin section at all. I have even tried to see if this problem occurs on another computer that has not accessed the site before, and it still happens. When the site first is accessed, the category is not dislayed in the Category box.

 

Categories

 

TransIt Series (1)

Trakker Series-> (17)

 

 

 

 

But when I click on one of the other categories, the other categories mysteriously appear again.

 

Categories

 

TransIt Series (1)

MediaMate Series-> (4)

Trakker Series-> (17)

 

 

 

 

Again, I cannot find any of the categories that I deleted in the database nor the products. Any further suggestions?

 

Thanks.

Link to comment
Share on other sites

I have created my own bug - but not really!!!! :-"

 

I installed a cache folder and set the cache up in Admin. I needed to delete the cache in the cashe folder after I deleted categories in the Admin as the cache was pushing the former pages in my browser. :blush:

 

So, hope my lack of knowledge and troubleshooting helps someone else :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...