Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

no images


greggmanning

Recommended Posts

I have got to grips with most of the configuration but unless I can solve this problem I am not going to be able to use ocommerce. To start with I have uploaded my images into the folder ocommerce/images. I have a mixture of gifs and jpg's. I have changed the permissions on the folders to 777. I have then gone into a new product page and where the box is I type in the image name and extension as i was told to do but when i click on the preview button nothing happens at all. I then tried to browse the image on my own system where I am not running it as a server but i do have the same folders and path names all except the root c: when i do this i get the following error message

 

Warning: move_uploaded_file(): open_basedir restriction in effect. File(/home2/scstamps/public_html/ocommerce/images/speed.gif) is not within the allowed path(s): (/home2/scstamps/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/scstamps/public_html/ocommerce/admin/includes/classes/upload.php on line 94

 

Error: File upload not saved.

Now this is not good but it at least tells me that it is now looking for an image.

 

Please will somebody explain the full process to me and if I need to make some adjustment to any php file or perhaps I have somehow not got images enabled but the test images on the default site show up okay. What I dont understand is that i have not yet deleted the default images but I can't even get these to load in a new page.

 

I am really desparate and have already spent a couple of days trying to work this one out.

 

Regards

Gregg

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...