Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

a Few Small Errors


breedingexotics

Recommended Posts

ok this is my problem when i go to:

Cache Control

i get this Error ~~~>

Warning: is_dir(): open_basedir restriction in effect. File(/httpdocs/shop/Cache/) is not within the allowed path(s): (/home/httpd/vhosts/breedingexotics.com/httpdocs:/tmp) in /home/httpd/vhosts/breedingexotics.com/httpdocs/shop/admin/cache.php on line 26
Error: Cache directory does not exist. Please set this Configuration->Cache.

I have Set this and it wont take for some reason i dont know why Any one know??

 

SECOND:

when i go to DATABASE BACKUP Then click BACK UP i get this:

 

Warning: file_exists(): open_basedir restriction in effect. File(/usr/bin/gzip) is not within the allowed path(s): (/home/httpd/vhosts/breedingexotics.com/httpdocs:/tmp) in /home/httpd/vhosts/breedingexotics.com/httpdocs/folder/admin/backup.php on line 424

Warning: file_exists(): open_basedir restriction in effect. File(/usr/local/bin/zip) is not within the allowed path(s): (/home/httpd/vhosts/breedingexotics.com/httpdocs:/tmp) in /home/httpd/vhosts/breedingexotics.com/httpdocs/folder/admin/backup.php on line 425

 

Any HELP would be GREAT Thanks in ADVANCED

Link to comment
Share on other sites

Firstly, your site is most likely to be on a shared server, so it is not advisable to cache files. So set Use Cache to False. That will get rid of one error.

 

Your folder for making backups should be in the admin folder, and by default is called backups (not backup). If you don't have this folder then create it. Then make sure that this is the setting used in admin/includes/configure.php

 

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

That takes care of the second error.

 

Vger

Link to comment
Share on other sites

Your folder for making backups should be in the admin folder, and by default is called backups (not backup).  If you don't have this folder then create it.  Then make sure that this is the setting used in admin/includes/configure.php

 

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

That takes care of the second error.

 

Vger

 

ok i have checked the files above and they are just like you say they should be and i am still getting the same error...

Link to comment
Share on other sites

I also get this error, even though I did everything by the book and the settings ARE correct. Help?

 

Ok, it does say that it has done a backup, but the error messages still bug me, seeing as I am about to install some contribs, and want my backup done properly first!

Link to comment
Share on other sites

  • 6 months later...
ok this is my problem when i go to:

Cache Control

i get this Error ~~~>

Warning: is_dir(): open_basedir restriction in effect. File(/httpdocs/shop/Cache/) is not within the allowed path(s): (/home/httpd/vhosts/breedingexotics.com/httpdocs:/tmp) in /home/httpd/vhosts/breedingexotics.com/httpdocs/shop/admin/cache.php on line 26
Error: Cache directory does not exist. Please set this Configuration->Cache.

I have Set this and it wont take for some reason i dont know why Any one know??

 

If I give too much info here bear with me-- I saw several unanswered threads when I came looking for an answer to the same problem, discovered the resolution and I'm going to cut and paste this resolution into each of these threads so if I overexplain forgive me-- take what you need and go ;)

 

In the OSC admin tool under 'Configuration' select 'Cache'. Set 'Use Cache' to true and set the 'Cache Directory' to THE FULL PATH to your cache directory. That means the full path from the root of the file system on your server. You can pull this most of this from your /catalogs/includes/configure.php file-- the 'DIR_FS_CATALOG' has the path you need, just add 'cache/' to the end. So in the example below:

 

define('DIR_FS_CATALOG', '/home/myhostingacct/public_html/catalog/');

 

Add 'cache/' to the end making it '/home/myhostingacct/public_html/catalog/cache/' (without the singles quotes)

 

Plug this into the 'Cache Directory' entry and save it. Make sure there there are CHMOD 777 (full read/write access for all) permissions to the cache folder and you should be golden.

 

TESTING

------------

 

From the Admin tool go to 'Tools' and select 'Cache Control'. That pesky pink error message at the top should be gone now. If not, something is wrong. Check the path and check the permissions, that's all that could be wrong.

 

Notice that the file 'date created' for the three cache files is 'File does not exist'. Now browse your site, click a couple of the categories, and select a manufacturer from the box. Then refresh the 'Cache Control' page. You should see that they are updated now. If so-- it's working... have a nice day!

Jerry a.k.a. 'FoundSoul'

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...