Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

plsssssss help me with language module


asinha

Recommended Posts

Lookt at this site

http://coolsunglasses.nl if u lick on the english flag, it will open a english version site but when i click on any other link on that page it opens up the site n dutch language, can anybody help me with this, as my site is live and my boss is ready to fire me.

please help all u gentlemen out there. :'(

Link to comment
Share on other sites

I can navigate to a product page then switch language (English to German). I can then browse the catalog in the German language just fine...add to cart, remove, update.

 

Bobby

Link to comment
Share on other sites

I am sorry I can't help with the problem, but I wanted to let others know that I experience the same problem. I switched to English and navigate categories just fine. When I click on 'home' it reverts to Dutch. While in English, I went to shipping info. When I clicked continue, it took me to the home page and I was back in Dutch again.

 

As I said I can't really help solve this as I have only one language on my sites. Hopefully what I reported will help somebody else pinpoint the solution.

Link to comment
Share on other sites

It's close for me. The language changes correctly, but the dutch flag is still the one selected, no matter what language. I can navigate through the site, and the language is preserved, except for the footer links. Two of them default to dutch, international shipping defaults to english.

 

Jeremy

Link to comment
Share on other sites

Hi bobby,

 

well can u help me why we are not able to to browse with taht particular language, why is it directing me to dutch languge all the time.

I will acept that my job will go if this is working at your end but not in our end....

i am able to view th english page but clickin on link in english page it opens the dutch language......can u give me any idea ??

:(

 

 

I can navigate to a product page then switch language (English to German).  I can then browse the catalog in the German language just fine...add to cart, remove, update.

 

Bobby

Link to comment
Share on other sites

thanx for reply jeremy, but when u choose language like english and then try clicking onthe right column where i have special product listing or u can try clicking on the left colum where the product list is there, they all take me to dutch language instead of english language as hoosen.

Please help

 

:(

 

It's close for me.  The language changes correctly, but the dutch flag is still the one selected, no matter what language.  I can navigate through the site, and the language is preserved, except for the footer links. Two of them default to dutch, international shipping defaults to english.

 

Jeremy

Link to comment
Share on other sites

thanx for reply, but when u choose language like english and then try clicking onthe right column where i have special product listing or u can try clicking on the left colum where the product list is there, they all take me to dutch language instead of english language as hoosen.

Please help

 

:(

 

 

I am sorry I can't help with the problem, but I wanted to let others know that I experience the same problem. I switched to English and navigate categories just fine. When I click on 'home' it reverts to Dutch. While in English, I went to shipping info. When I clicked continue, it took me to the home page and I was back in Dutch again.

 

As I said I can't really help solve this as I have only one language on my sites. Hopefully what I reported will help somebody else pinpoint the solution.

Link to comment
Share on other sites

Your header links are a bit screwy too. Sometimes they revert to dutch, sometimes not. As I said, I can navigate the left, main and right column, and the language stays the same, the flag is always dutch, and the header and footer links are the ones that are wrong for me. The header tags don't switch to english, unless I click on one, the dutch page will open, and if I switch back to English again it will translate the links and stay.

 

Jeremy

Link to comment
Share on other sites

I HAVE REMOVED THE HARDCODED VALUES FROM

<a href="http://coolsunglasses.nl/order/product_info.php?cPath=34&products_id=118&osCsid=e86c3990734f0fc868b8eb32802e661f">

 

TO

 

<a href="http://coolsunglasses.nl/order/product_info.php?cPath=34&products_id=118">

 

BUT STILL GET THE SAME PROBLEM, ALSO IN LEFT COLUM I CANT NAVIGATE WITH PROPER LANGUAGE.

 

help

 

 

 

how can i change that, i am new to PHP, PLEASE SAVE ME

Link to comment
Share on other sites

You have to use tep_href_link() to form the URLs or you'll have session problems (dropped carts, languages, etc).

 

Bobby

Link to comment
Share on other sites

YES COS U CAN SEE THAT WE ARE PASSING THE LANGUAGE AS ?language=en or what ever thats why u can navigate but why not in other links, its hard to pass language as parameter to every link. i believe OSC doesn't work this way.

 

HELP

 

Your header links are a bit screwy too.  Sometimes they revert to dutch, sometimes not.  As I said, I can navigate the left, main and right column, and the language stays the same, the flag is always dutch, and the header and footer links are the ones that are wrong for me.  The header tags don't switch to english, unless I click on one, the dutch page will open, and if I switch back to English again it will translate the links and stay.

 

Jeremy

Link to comment
Share on other sites

You don't have to pass it in every link. Once you click on a link with the language parameter it saves that setting in session. That is why you're having problems with the language...the other links had hardcoded sessionID's.

 

If you simply create the language links with the correct parameter and use tep_href_link() to form ALL URLs it'll work for you.

 

Bobby

Link to comment
Share on other sites

can u pls help in how to pass tep_href_link() and in which file do i need to pass and how?? pls pls help

 

 

You don't have to pass it in every link.  Once you click on a link with the language parameter it saves that setting in session.  That is why you're having problems with the language...the other links had hardcoded sessionID's.

 

If you simply create the language links with the correct parameter and use tep_href_link() to form ALL URLs it'll work for you.

 

Bobby

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...