Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error entering new products


mallary68

Recommended Posts

I am trying to enter my products in admin. I have entered my catagories and it allowed me to enter one product. The product is showing in my database. When I try to enter other products I get the following error:

 

1062 - Duplicate entry '0' for key 1

 

insert into products (products_quantity, products_model, products_price, products_date_available, products_weight, products_status, products_tax_class_id, manufacturers_id, products_image, products_date_added) values ('6', '275PR', '17.49', null, '.5', '1', '1', '', 'two bush island.jpg', now())

 

[TEP STOP]

 

These products are not showing in my database. I don't know what the error means or how to correct it. Am I doing something obviously wrong. After I enter the product and it uploads (it does say that the file has been saved) I click on insert. Is that what I am doing wrong? I tried to find the answer to this in the forum but was unable to locate anything specific to my problem.

 

Any help would be appreciated. Thank you!

Link to comment
Share on other sites

Make sure that you are using the database to store sessions, and not files. Make sure that the last line of both your configure.php file reads 'mysql' where indicated.

 

Vger

Link to comment
Share on other sites

I changed the last line of both configure.php files to read mysql. When I went into admin to see if this worked I received the following error:

 

Error: Catalog images directory does not exist: /hsphere/local/home/teemcorp/downeastfashions.com//catalog/images/

 

I did not change anything else in my configure files. I have removed the catalog file all together and the images file is in the root. What would have caused this error? Or what would cause it to look for the catalog file all of the sudden?

 

Thank you again.

Link to comment
Share on other sites

Check the admin/includes/configure.php to see if the entries below match what you have:

 

http_server = 'http://www.yourdomain.com'

dir_ws_catalog = '/catalog/'

 

In the error you have there is a double slash after your domain name, and this may be because you have a trailing slash on the end of the http_server address, as in:

 

http_server = 'http://www.yourdomain.com/'

 

If you have moved the folders from 'catalog' to the root then the dir_ws_catalog entry would read: '/'

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...