Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Images Not showing on secure pages


Guest

Recommended Posts

:blush: I love the oscommerce cart, I was using agora, and am in the proccess of switching to oscommerce. I am still in the early stages. I have slamed myself into TWO problems. One: once I secured my cart check out, the images disapeared. I have tried fooling around with the configure.php with no luck. I have tried typing full image paths, and still no luck. I am using a shared ssl certificate.

My configure.php looks like this ---at the moment

/*
?$Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $

?osCommerce, Open Source E-Commerce Solutions
?http://www.oscommerce.com

?Copyright (c) 2003 osCommerce

?Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://sweetdeal4u.biz');
define('HTTPS_SERVER', 'https://svr73.ehostpros.com/~sweetd73');
?define('ENABLE_SSL', false); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', 'http://sweetdeal4u.biz/');
define('HTTPS_COOKIE_DOMAIN', 'https://svr73.ehostpros.com/~sweetd73');
define('HTTP_COOKIE_PATH', '/catalog/');
define('HTTPS_COOKIE_PATH', 'www.sweetdeal4u.biz/catalog/');
define('DIR_WS_HTTP_CATALOG', '/catalog/');
define('DIR_WS_HTTPS_CATALOG', '/');
define('DIR_WS_IMAGES', '/catalog/images');
define('DIR_WS_ICONS', '/catalog/images/icons/');
?define('DIR_WS_INCLUDES', 'includes/');
?define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
?define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
?define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
?define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
?define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

?define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
?define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));
?define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
?define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
define('DB_SERVER', 'localhost');
define('DB_SERVER_USERNAME', 'sweetd73_osc1');
define('DB_SERVER_PASSWORD', '_tX5gEHg9T');
define('DB_DATABASE', 'sweetd73_osc1');
?define('USE_PCONNECT', 'false'); // use persistent connections?
define('STORE_SESSIONS', 'mysql');

thelink to my shop is: http://www.sweetdeal4u.biz/catalog/index.php the images work fine untill you go to a secure page.... Any help would be greatly apreciated!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...