Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cell padding/spacing on main page


raeB

Recommended Posts

1)My greeting text "Welcome Guest! Would you like to log yourself in? Or would you prefer to create an account?",

2)Title heading and

3)"Whats new in March" box

 

all begin too close to the left margin and consiquently everything looks squashed up against the left column.

 

I cant seem to find the right table in index.php that can control the cell spacing and cell pading of this table, so I can make the text and what's new box start furthur away from the left column.

 

Thanks!

Link to comment
Share on other sites

1)My greeting text "Welcome Guest! Would you like to log yourself in? Or would you prefer to create an account?",

2)Title heading and

3)"Whats new in March" box

 

all begin too close to the left margin and consiquently everything looks squashed up against the left column.

 

I cant seem to find the right table in index.php that can control the cell spacing and cell pading of this table, so I can make the text and what's new box start furthur away from the left column.

 

Thanks!

 

 

 

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_default.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="main"><?php echo tep_customer_greeting(); ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td class="main"><?php echo TEXT_MAIN; ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?></td>

</tr>

<?php

include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS);

?>

</table></td>

</tr>

</table>

 

 

 

That is the code for the main index page table cell with the welcome greeting in it.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

<table border="0" width="100%" cellspacing="0" cellpadding="0">

      <tr>

        <td><table border="0" width="100%" cellspacing="0" cellpadding="0">

          <tr>

            <td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

            <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_default.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

          </tr>

        </table></td>

      </tr>

      <tr>

        <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

      </tr>

      <tr>

        <td><table border="0" width="100%" cellspacing="0" cellpadding="0">

          <tr>

            <td class="main"><?php echo tep_customer_greeting(); ?></td>

          </tr>

          <tr>

            <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

          </tr>

          <tr>

            <td class="main"><?php echo TEXT_MAIN; ?></td>

          </tr>

          <tr>

            <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

          </tr>

          <tr>

            <td><?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?></td>

          </tr>

<?php

    include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS);

?>

        </table></td>

      </tr>

    </table>

That is the code for the main index page table cell with the welcome greeting in it.

 

 

Yea this IS the table however it doesnt work, at least not for the main page, it works when a category is clicked just not on the main page, I mustve done something to the code somewhere. :(

Link to comment
Share on other sites

Yea this IS the table however it doesnt work, at least not for the main page, it works when a category is clicked just not on the main page, I mustve done something to the code somewhere. :(

 

I just installed another fresh copy of OSC 2.2MS2 to test it out and the same thing happens, modifying that particular tables attributes only seems to have an effect when categories are being displayed. It should affect the main page too because it is the same table but its not working.

 

So is this a bug? is there a way around it?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...