Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

htaccess problem


hondauser85

Recommended Posts

but obviously something is wrong i get the login prompt when i try to access my admin folder i saw this in another .htaccess folder in a different directory and this is what its tellin me >>>>>>>This is used with Apache WebServers

# The following blocks direct HTTP requests in this directory recursively

#

# For this to work, you must include the parameter 'Limit' to the AllowOverride configuration

#

# Example:

#

#<Directory "/usr/local/apache/htdocs">

# AllowOverride Limit

#

# 'All' with also work. (This configuration is in your apache/conf/httpd.conf file)

#

# This does not affect PHP include/require functions

#

# Example: http://server/catalog/includes/application_top.php will not work

 

<Files *.php>

Order Deny,Allow

Deny from all

</Files>

 

 

 

 

 

please help me to get this thing to work its driving me crazy....lol

Link to comment
Share on other sites

but obviously something is wrong i get the login prompt when i try to access my admin folder i saw this in another .htaccess folder in a different directory and this is what its tellin me >>>>>>>This is used with Apache WebServers

# The following blocks direct HTTP requests in this directory recursively

#

# For this to work, you must include the parameter 'Limit' to the AllowOverride configuration

#

# Example:

#

#<Directory "/usr/local/apache/htdocs">

#  AllowOverride Limit

#

# 'All' with also work. (This configuration is in your apache/conf/httpd.conf file)

#

# This does not affect PHP include/require functions

#

# Example: http://server/catalog/includes/application_top.php will not work

 

<Files *.php>

Order Deny,Allow

Deny from all

</Files>

please help me to get this thing to work its driving me crazy....lol

 

Hi,

 

If at all possible I would suggest you use the password protect directory function in you host control panels. You .htaccess file should actually have a section in it that looks like this:

 

AuthType Basic

AuthName "Restricted Area"

AuthUserFile "/home/xxx/.htpasswds"


require valid-user

 

 

To function correctly there is also an .htpasswd file which includes an encrypted password for the user account. The utility makes this all a snap to do. There is also a command line utility that can be used as well.

 

Regards,

 

Tina

If you're not having fun you're not doing it right

 

Teach a person to fish rather than give them a loaf of bread or however that saying goes.

Link to comment
Share on other sites

Hi,

 

If at all possible I would suggest you use the password protect directory function in you host control panels. You .htaccess file should actually have a section in it that looks like this:

 

AuthType Basic

AuthName "Restricted Area"

AuthUserFile "/home/xxx/.htpasswds"
require valid-user

To function correctly there is also an .htpasswd file which includes an encrypted password for the user account. The utility makes this all a snap to do. There is also a command line utility that can be used as well.

 

Regards,

 

Tina

please help me i cant figure it out

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...