Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

PopTheTop

Fancier Invoice & Packingslip v1.0

Recommended Posts

I just installed 5.1.

 

I tried both outlook 2003 and outlook express 6 and the emails are not html, they look like regular text as before. Html is selected in the admin.

 

Regarding the locals/configure.php file I added, only the top line (the line pointing to admin) needed to be updated right? I didn't have to do anything with the other 5 lines right?

Share this post


Link to post
Share on other sites
Guest

Hi Scooter,

Firstly thank you for this contrib, the invoice in particular looks much better! :thumbsup:

 

Secondly a minor point regarding some hard coding which I hope you can look at.

The Address formats seem hard coded as this....

<td>    <?php echo tep_address_format($order->customer['format_id'], $order->customer, 1, '', '<br>    '); ?></td>

 

I believe it is this 1 after $order->customer, that is causing the problems for us, as I think this is the calling the first address format in the database, which is of an American Format. What we`d like is format number 4 or for the function to be pulled from general.php like it is I believe in the rest of the site.

 

I have tried just changing that red 1 in the 2 places necessary in invoice.php to 4 but it didnt change the format at all.

I was wondering if you had a spare 2 mins if you could shed any light on this situ.

 

Thanks again for this great Contrib!

Edited by Reesy

Share this post


Link to post
Share on other sites
I have just incorporated this contribution into my site today, initially V5.0 and now updated to V5.1

 

I have however struck a problem and would appreciate any assistance with it.  The problem occurs when I try to type information in the Customer Comments section on checkout.

 

If there are no comments I receive the invoice ok with the normal 'No comments have been left for this order' tag.  However when I add comments I receive this error:

 

Fatal error: Cannot instantiate non-existent class: objectinfo in /home/signed/public_html/includes/modules/email_invoice/templates/fancy.php on line 289

 

BTW I was receiving this error earlier when I first loaded V5.0 but thought it might have fixed itself when I went through the installation of V5.1 again, but obviously not.

 

Any ideas please?

I'm getting the same error but I installed 5.1 so my file is html_invoice.php but the same line.

 

Any ideas?

 

Dave.

Share this post


Link to post
Share on other sites
I'm getting the same error but I installed 5.1 so my file is html_invoice.php but the same line.

 

Any ideas?

 

Dave.

I guess I spoke too soon:

 

1. When the order has comments:

  1. I get
    Fatal error: Cannot instantiate non-existent class: objectinfo in /home/signed/public_html/includes/modules/email_invoice/templates/fancy.php on line 289
    in the comment box and I can't do anything else since there are no buttons
  2. the order shows up in the admin but no email is sent
  3. the cart is not reset
  4. even if you delete the shopping cart, the comment stays unless you log out and then log back in; even if you delete the item in the cart and add something else, it keeps the comment

2. When I place an order and don't put any comments:

  1. it sends an html email that looks like the web site layout but is blank (no order info)
  2. the email has STORE_OWNER_EMAILS_FROM_NAME in the from line
  3. the shopping cart doesn't reset and the product stays in the cart
  4. the invoice doesn't show so the customer doesn't get an option to print the invoice, they just get sent straight back to the main page

I would like to say that from what I can see so far this looks to be awesome. I especially like how it sends the main page in the email.

 

Thanx, Dave.

Share this post


Link to post
Share on other sites

Thanks for the great contribution. Almost everything works smooth like... ;) But I'm having severe troubles using "Print invoice" option. It prints out only the basic template of my shop but no contents on it. Same with HTML-invoices.

 

You may reproduce this behaviour at http://www.amk-kustannus.fi/verkkokauppa , however as this is a live shop, I ask you to add a comment on your order that you are just testing on my (Marko Kulmala) request. Try "Advance payment by bank transfer" as payment method so you don't need to mix up everything with PayPal.

 

Thanks in advance! :thumbsup:

 

Marko


--

Live long and prosper! :)

 

Contributions:

Full Finnish language pack

Share this post


Link to post
Share on other sites

I just installed v 5.1. All the info is there and works fine on the screen. However, when I print an invoice, the outlines of the boxes do not line up correctly. the horizontals are lower and the left hand verticals are pushed to the right, except for the very centre vertical - that is in the correct line with the corners. the shading works as it should.

 

I am using Safari v2.0 on Mac OS 10.4. background printing of images is turned ON.

 

I'm not sure if anyone is able to solve this problem for me. But other Mac users best be aware of this issue before they install. As always, make a BACKUP of everything so that you can go back to what you had if it doesn't work out.

Share this post


Link to post
Share on other sites
I have just incorporated this contribution into my site today, initially V5.0 and now updated to V5.1

 

I have however struck a problem and would appreciate any assistance with it.  The problem occurs when I try to type information in the Customer Comments section on checkout.

 

If there are no comments I receive the invoice ok with the normal 'No comments have been left for this order' tag.  However when I add comments I receive this error:

 

Fatal error: Cannot instantiate non-existent class: objectinfo in /home/signed/public_html/includes/modules/email_invoice/templates/fancy.php on line 289

 

BTW I was receiving this error earlier when I first loaded V5.0 but thought it might have fixed itself when I went through the installation of V5.1 again, but obviously not.

 

Any ideas please?

 

 

Actually, I just found that bug myself this morning. I am working on it now. But I too are having problems fixing this. It works just fine through the site, but as the order HTML invoice, it messes up. Try adding at the top of includes/modules/email_invoice/templates/fancy.php the following:

 

  require('includes/application_top.php');


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
well it all looks nice untill you goto print invoice from

order history info and you get this

print.GIF

 

i know i have to change logo

 

or have i missed something

 

regards Andy

 

 

That is because I have not finished with the customer print invoice yet. That is the stock osC view and will remain that way until I get 2 small bugs removed/fixed.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
I am using Fancier Invoice 5.1 and was wondering if I can ge the software to display a new database category products_sku in the emailed invoiced as the SKU number stored.  Any ideas?

 

 

Sorry, but I do not understand what you mean? Also, what software???


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
I just installed 5.1.

 

I tried both outlook 2003 and outlook express 6 and the emails are not html, they look like regular text as before.  Html is selected in the admin.

 

Regarding the locals/configure.php file I added, only the top line (the line pointing to admin) needed to be updated right?  I didn't have to do anything with the other 5 lines right?

 

I think it is broken. I tried this with yahoo webmail also and no html in the emails?

 

What is it supposed to look like?

Share this post


Link to post
Share on other sites

Still about Print invoice -function. When I point the button with mouse the link address apperas as:

 

java script:popupPrintReceipt('http://www.amk-kustannus.fi/verkkokauppa/print_my_invoice.php?order_id=2069')

 

And this is what happens: empty popup-window... or without order details. Any ideas? Also, this apperas similar way in html-invoices... no order details but the web page structure anyway.

 

Any help would be muc appreciated.

 

print_problem.jpg

 

Makro :blush:


--

Live long and prosper! :)

 

Contributions:

Full Finnish language pack

Share this post


Link to post
Share on other sites
I think it is broken.  I tried this with yahoo webmail also and no html in the emails?

 

What is it supposed to look like?

 

 

Non HTML is supposed to look like the stock osC text e-mailed invoice.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Still about Print invoice -function. When I point the button with mouse the link address apperas as:

 

java script:popupPrintReceipt('http://www.amk-kustannus.fi/verkkokauppa/print_my_invoice.php?order_id=2069')

 

And this is what happens: empty popup-window... or without order details. Any ideas? Also, this apperas similar way in html-invoices... no order details but the web page structure anyway.

 

Any help would be muc appreciated.

 

print_problem.jpg

 

Makro  :blush:

 

 

not sure because it works on my site. Did you install all the files included in the MOD and follow all the instructions?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
not sure because it works on my site. Did you install all the files included in the MOD and follow all the instructions?

 

Yes, made it twice... Does it affect if I use STS? I think not, but just to make sure. Anyway, I'll try again.

 

Marko


--

Live long and prosper! :)

 

Contributions:

Full Finnish language pack

Share this post


Link to post
Share on other sites
Yes, made it twice... Does it affect if I use STS? I think not, but just to make sure. Anyway, I'll try again.

 

Marko

 

 

Not sure because I do not have STS and know nothing about it. Did you try going directly to http://www.amk-kustannus.fi/verkkokauppa/p...p?order_id=2069 ?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Hi Scooter,

Firstly thank you for this contrib, the invoice in particular looks much better!  :thumbsup:

 

Secondly a minor point regarding some hard coding which I hope you can look at.

The Address formats seem hard coded as this....

<td>    <?php echo tep_address_format($order->customer['format_id'], $order->customer, 1, '', '<br>    '); ?></td>

 

I believe it is this 1 after $order->customer, that is causing the problems for us, as I think this is the calling the first address format in the database, which is of an American Format. What we`d like is format number 4 or for the function to be pulled from general.php like it is I believe in the rest of the site.

 

I have tried just changing that red 1 in the 2 places necessary in invoice.php to 4 but it didnt change the format at all.

I was wondering if you had a spare 2 mins if you could shed any light on this situ.

 

Thanks again for this great Contrib!

 

 

Sorry, you are on your own with thisone. I do not know how and I only run the shop with the English language.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
I have just incorporated this contribution into my site today, initially V5.0 and now updated to V5.1

 

I have however struck a problem and would appreciate any assistance with it.  The problem occurs when I try to type information in the Customer Comments section on checkout.

 

If there are no comments I receive the invoice ok with the normal 'No comments have been left for this order' tag.  However when I add comments I receive this error:

 

Fatal error: Cannot instantiate non-existent class: objectinfo in /home/signed/public_html/includes/modules/email_invoice/templates/fancy.php on line 289

 

BTW I was receiving this error earlier when I first loaded V5.0 but thought it might have fixed itself when I went through the installation of V5.1 again, but obviously not.

 

Any ideas please?

 

 

 

Ok, this is now fixed.

To do a quick update, just add the following at the top of includes/modules/email_invoice/templates/fancy.php or includes/modules/email_invoice/templates/html_invoice.php (depending on the file you actually have)

 

 

// class constructor
   function objectInfo($object_array) {
     reset($object_array);
     while (list($key, $value) = each($object_array)) {
       $this->$key = tep_db_prepare_input($value);
     }
   }
 }

 

 

Just above:

?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>

 

 

This should fix that error you get when you checkout and have comments.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

I am looking into the cart thing, I am trying to find out why the cart does not reset after checkout_process.php


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Non HTML is supposed to look like the stock osC text e-mailed invoice.

 

That's what my html emails look like, just text.

 

Tried yahoo webmail, outlook xpress 6, outlook 2003. All are set to receive html.

 

regarding locals/configure.php

 

of the 6 entries, only the first line needed to be modified right?

 

Can anyone include a pic of their html email ?

Share this post


Link to post
Share on other sites
That's what my html emails look like, just text.

 

Tried yahoo webmail, outlook xpress 6, outlook 2003.  All are set to receive html.

 

regarding locals/configure.php

 

of the 6 entries, only the first line needed to be modified right? 

 

Can anyone include a pic of their html email ?

 

 

Edit or add ALL of them unless you already have those lines in that file already.

 

If you have the latest release of v5.1 thne the html_invoice looks just like the Admin Order Invoices.

 

Make sure you have your store setup to send MINE HTML e-mails and then make sure you have it set to Send HTML or Text Invoices to Customers. Both should be set to true in Admin / Configuration / E-mail Options

 

Also, set your HTML invoice template file to html_invoice.php in Admin / Configuration / E-mail Options


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
I am looking into the cart thing, I am trying to find out why the cart does not reset after checkout_process.php

 

 

Guys, I need help here...

I can not find what is causing the shopping cart to not clear and reset itself at checkout.

 

I think I have checkout_process.php modified correctly, if you look at the bottom of tat file, you can see where it resets the shopping carts, but it is not working.

 

Does anyone have any clues here?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Here is an update of what is happening with the code suggestions so far

 

NO COMMENTS:

* The checkout goes from CONFIRMATION to FINISHED to the MAIN PAGE and doesn't give the customer the option to print the invoice. Is this the way it is supposed to work?

 

* The html email is received but the from has "STORE_OWNER_EMAILS_FROM_NAME [christina@christinajs.com]". The email has the web page layout but no actual order info. Is this the part that is not implemented yet? If it is then I will stop mentioning it.

 

* The cart is not resetting.

 

WITH COMMENTS:

* When I have this code at the top of html_invoice.php

<?php
/*
 $Id: invoice.php,v 5.1 2005/05/07 00:37:30 PopTheTop Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

?>

<script language="javascript"><!--
// class constructor
  function objectInfo($object_array) {
    reset($object_array);
    while (list($key, $value) = each($object_array)) {
      $this->$key = tep_db_prepare_input($value);
    }
  }
//--></script>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<title><?php echo STORE_NAME; ?> <?php echo INVOICE_TEXT_INVOICE; ?> <?php echo INVOICE_TEXT_NUMBER_SIGN; ?><?php echo INVOICE_TEXT_CURRENT_YEAR; ?><?php echo INVOICE_TEXT_DASH; ?><?php echo $oID; ?></title>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<link rel="stylesheet" type="text/css" href="<?php echo $ei_css_path; ?>stylesheet.css">

I get this error when the order process goes from CONFIRMATION to FINISHED:

Fatal error: Cannot instantiate non-existent class: objectinfo in /home/cjadmin/public_html/includes/modules/email_invoice/templates/html_invoice.php on line 299

* When I have this code at the top of html_invoice.php

<?php
/*
 $Id: invoice.php,v 5.1 2005/05/07 00:37:30 PopTheTop Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

require('includes/application_top.php');

?>

<script language="javascript"><!--
// class constructor
  function objectInfo($object_array) {
    reset($object_array);
    while (list($key, $value) = each($object_array)) {
      $this->$key = tep_db_prepare_input($value);
    }
  }
//--></script>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<title><?php echo STORE_NAME; ?> <?php echo INVOICE_TEXT_INVOICE; ?> <?php echo INVOICE_TEXT_NUMBER_SIGN; ?><?php echo INVOICE_TEXT_CURRENT_YEAR; ?><?php echo INVOICE_TEXT_DASH; ?><?php echo $oID; ?></title>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<link rel="stylesheet" type="text/css" href="<?php echo $ei_css_path; ?>stylesheet.css">

I get this error

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/cjadmin/public_html/includes/functions/database.php:13) in /home/cjadmin/public_html/includes/functions/database.php on line 13
on a blank white page but the order does show as completed.

 

* The cart does not reset.

 

FYI: I am useing STS. If you want I can disable STS and see if I still have the same problems but it will be awhile before I can reply.

 

Thanx, Dave.

Share this post


Link to post
Share on other sites
NO COMMENTS:

* The checkout goes from CONFIRMATION to FINISHED to the MAIN PAGE and doesn't give the customer the option to print the invoice. Is this the way it is supposed to work?

Yes, that is normal and nothing wrong there...

 

 

 

* The html email is received but the from has "STORE_OWNER_EMAILS_FROM_NAME [christina@christinajs.com]". The email has the web page layout but no actual order info. Is this the part that is not implemented yet? If it is then I will stop mentioning it.

 

Change STORE_OWNER_EMAILS_FROM_NAME to STORE_OWNER in catalog\includes\modules\email_invoice\email_invoice.php

 

 

 

 

* The cart is not resetting.

 

I know this, if you read the above post, I am still trying to fix that.

 

 

===============================

 

 

 

WITH COMMENTS:

* When I have this code (the update posted) at the top of html_invoice.php - I get this error on a blank white page but the order does show as completed.

 

 

DELETE the following line:

require('includes/application_top.php');

 

 

It should look like this...

 ?Released under the GNU General Public License
*/

// class constructor
? ?function objectInfo($object_array) {
? ? ?reset($object_array);
? ? ?while (list($key, $value) = each($object_array)) {
? ? ? ?$this->$key = tep_db_prepare_input($value);
? ? ?}
? ?}
?}

?>

 

I have no idea where you got the javascript stuff???

Edited by PopTheTop

L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Guys, I need help here...

I can not find what is causing the shopping cart to not clear and reset itself at checkout.

 

I think I have checkout_process.php modified correctly, if you look at the bottom of tat file, you can see where it resets the shopping carts, but it is not working.

 

Does anyone have any clues here?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

This is a quick fix and I do not know if it is the correct one or not, BUT... It works...

 

I opened checkout_success.php and added this to the top:

 

  $cart->reset(true);

 

Just above:

 

?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

 

 

I still do not know why $cart->reset(true); does not work in checkout_process.php any longer.

 

Anyone???


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×