Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installation errors - configuration files


safire

Recommended Posts

I"m trying to install osCommerce but I keep getting errors when connecting to my server:

 

 

The following error has occurred:

 

 

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /home/httpd/vhosts/oregonliteracy.org/httpdocs/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /home/httpd/vhosts/oregonliteracy.org/httpdocs/catalog/admin/includes/

touch configure.php

chmod 706 configure.php

 

If chmod 706 does not work, please try chmod 777.

 

If you are running this installation procedure under a Microsoft Windows environment, try renaming the existing configuration file so a new file can be created.

 

The config file IS THERE, the database is connecting and downloaded the tables.. i'm not sure where the glitch is in the process..

 

Also I added the register_globals patch from here: http://www.oscommerce.com/community/contri...egister_globals

which is the first one on the top.

 

This might be causing the problem...can anyone help? maybe a different patch for the register_globals that I could use that would work better? or perhaps it's just a problem with my files being in the wrong place.. i dunno.

 

help? anyone?

Link to comment
Share on other sites

Sounds like when you did the install your configure.php files needed to be set to chmod 706 or above, and weren't. Check to see what's actually in them, they may just be blank files with no pathways.

 

The Register Globals patch allows your site to run with register globals set to off - but bear this in mind, if you use this patch the server you are on MUST have register globals set to Off.

 

Vger

Link to comment
Share on other sites

how do I set my configure.php to chmod 706? or better yet.. what is it and where can I read more about it?

 

I went to my c-panel and changed the premissions of the configure.php to be writeable by other sources and readable.. is that what you were talking about? That didn't work either..

 

-MK

 

 

Sounds like when you did the install your configure.php files needed to be set to chmod 706 or above, and weren't.  Check to see what's actually in them, they may just be blank files with no pathways.

 

The Register Globals patch allows your site to run with register globals set to off - but bear this in mind, if you use this patch the server you are on MUST have register globals set to Off.

 

Vger

Link to comment
Share on other sites

as for registar_globals, yes those are turned off already.. my host will not allow them to be turned on.

 

am I supposed to edit the configure.php file? I thought that was the install was for right? Is there something else i'm missing? This is what it looks like now:

and through the install process no data is added..

 

<?php

/*

  $Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $

 

  osCommerce, Open Source E-Commerce Solutions

  http://www.oscommerce.com

 

  Copyright © 2003 osCommerce

 

  Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

  define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers

  define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

  define('ENABLE_SSL', false); // secure webserver for checkout procedure?

  define('HTTP_COOKIE_DOMAIN', '');

  define('HTTPS_COOKIE_DOMAIN', '');

  define('HTTP_COOKIE_PATH', '');

  define('HTTPS_COOKIE_PATH', '');

  define('DIR_WS_HTTP_CATALOG', '');

  define('DIR_WS_HTTPS_CATALOG', '');

  define('DIR_WS_IMAGES', 'images/');

  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

  define('DIR_WS_INCLUDES', 'includes/');

  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

  define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

  define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

  define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers

  define('DB_SERVER_USERNAME', '');

  define('DB_SERVER_PASSWORD', '');

  define('DB_DATABASE', 'osCommerce');

  define('USE_PCONNECT', 'false'); // use persistent connections?

  define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

I really don't know much about cPanel, a I use the Ensim Control Panel myself. But you should be able to get FTP access to your website, and as long as the server is Linux or Unix (not Windows) then you can alter your file permissions via FTP. FTP to the site, locate the file, right click on it, and follow the procedure from there for altering file permissions (CHMOD).

 

Vger

Link to comment
Share on other sites

I am working in a Windows by the way..

 

Thanks for your help. I was forgetting to edit the configure.php file in the admin directory as well, finaly caught on to what I was doing. Thanks for the heads up.

Link to comment
Share on other sites

how do I set my configure.php to chmod 706? I went to my c-panel and changed the premissions of the configure.php to be writeable by other sources and readable.. is that what you were talking about? That didn't work either..

 

Hi, MK!

 

You can't set the chmod via cPanel. You have to do it with an ftp program. Personally, I use Filezilla (it's freeware). I LOVE this software!! It allows you to see the remote files, and if you right click on one, and select "File Properties", it allows you to set the "number" you want the file set to. It also has check boxes that effect the setting (read, write, and execute), so you can see (and learn) what each setting does.

 

Hope this helps! :)

 

Tami

Tami Jones

Sibemom2002

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...