Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

problem with default language


suski78

Recommended Posts

Hi,

 

Does anyone know, why my default language won't work?

I've set default language from admin site to english, but when I open my shop, default language is something else.

If I use languages box and click the correct language from there, everything works fine, but my shop is only in English, so I want to get rid of the langauge box, by setting the default language to English.

 

I also checked, that in configuration table my default language is set to 'en'.

 

Any ideas, what settings am I missing?

 

Thanks!

Link to comment
Share on other sites

Okay, first thing is to delete all of your temporary internet files, and all 'offline' files stored on your computer - because the change may have been made but you may still be seeing old pages which were cached on your computer.

 

Next, which country are you in? If you are using English for your website but you are in a country where english is not the language, then your browser may be looking for the files of another language. So, delete those other languages from the osCommerce 'admin' control panel (you can always just click to reinstall later).

 

Vger

Link to comment
Share on other sites

  • 9 months later...
To avoid this problem in future, set your browser to update cached pages 'every visit'.

 

Vger

 

The problem still persists in a case if I have several languages on my site, but want to specify the particular one for a new visitor to start from. It always opens in English, no matter which language is set as the default one.

 

OSC 2.2 MS2

Link to comment
Share on other sites

The problem still persists in a case if I have several languages on my site, but want to specify the particular one for a new visitor to start from. It always opens in English, no matter which language is set as the default one.

 

OSC 2.2 MS2

 

osCommerce also detects the browser's default language and takes that into account. What are your browser's language settings like?

 

 

 

Cheers,

 

Kalle!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...