Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can't connect to db server


kate4567

Recommended Posts

I am getting this error when I try to install:

 

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /home/www/asmartgift.com/includes/functions/database.php on line 19

Unable to connect to database server!

 

(My first installation appeared to be successful but it wasn't, and I have gone through some steps that someone on this list walked me thru, and now I can't even get into the installation process anymore).

 

Thanks for any help you can give!

Link to comment
Share on other sites

go to your domain via http://whatever and at catalog put /install

 

it failed because the file permissions were not set up properly per the knowledge base installation procedure (you did follow that?)

and then the store was half installed.

 

thus to reinstall, you need to now add the install/index.php to your normal installation and follow it completely through.

 

so please, follow the knowledge base installation procedure, it tells you what you need to do ahead of time, instead of after the fact.

Link to comment
Share on other sites

go to your domain via http://whatever and at catalog put /install

 

it failed because the file permissions were not set up properly per the knowledge base installation procedure (you did follow that?)

and then the store was half installed.

 

thus to reinstall, you need to now add the install/index.php to your normal installation and follow it completely through.

 

so please, follow the knowledge base installation procedure, it tells you what you need to do ahead of time, instead of after the fact.

 

I followed the knowledge base installation procedure carefully and I read it thru about ten times. I've done everything there and everything you told me to do (including the reinstallation using install/index.php, and the chmod changes) and I continue to get the above error message, even though the installation process tells me I've been successful. I am able to get into admin until I change the chmod for the two files back to read-only. But I am never able to access my actual web site, no matter what.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...