Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

checkout_success.php / parse error


Madinson

Recommended Posts

Parse error: parse error, unexpected $ in /var/www/web6/html/shop/catalog/checkout_success.php on line 32

 

at the end of the ordeer process i get this error.....any help

just create...and sell..sell...sell.....

Link to comment
Share on other sites

when you have a parse error, we can not help unless we can see the code, thus post 5 lines before and after the error . ..

 

else we may need to be psychic, . . .

Link to comment
Share on other sites

<br />

<b>Parse error</b>: parse error, unexpected $ in <b>/var/www/web6/html/shop/catalog/checkout_success.php</b> on line <b>32</b><br />

 

...this is the whole code of the site which is shown on the browser....

i can't fix the problem....any halp please??

just create...and sell..sell...sell.....

Link to comment
Share on other sites

...in the adminarea there is the order correctly, but how i told....I don't get the success-Site. Instead of this I get the blank page with the posted text...

just create...and sell..sell...sell.....

Link to comment
Share on other sites

This is the code from line 32 of your checkout_success.php page

 

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CHECKOUT_SUCCESS);

 

Which means that it cannot find that page. Look through your files to make sure that the page exists.

 

Vger

Link to comment
Share on other sites

<?php

/*

$Id: checkout_success.php,v 1.48 2003/02/17 11:51:16 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

 

// if the customer is not logged on, redirect them to the shopping cart page

if (!tep_session_is_registered('customer_id')) {

tep_redirect(tep_href_link(FILENAME_SHOPPING_CART));

}

 

if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'update')) {

$notify_string = 'action=notify&';

$notify = $HTTP_POST_VARS['notify'];

if (!is_array($notify)) $notify = array($notify);

for ($i=0, $n=sizeof($notify); $i<$n; $i++) {

$notify_string .= 'notify[]=' . $notify[$i] . '&';

}

if (strlen($notify_string) > 0) $notify_string = substr($notify_string, 0, -1);

 

tep_redirect(tep_href_link(FILENAME_DEFAULT, $notify_string));

}

 

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CHECKOUT_S

 

 

...and then NOTHING!!!!!!!! (on the server)...

So sorry...that was an ftp-mistake. I think the ftp-tool stopped while transmitting the file!!!

This is the first time I had this. I think without your posts I would be searching for an answer until it is christmas!!!

I pumped up the original version...and (why not) everything is ALRIGHT!

 

Thx anyway!!!!

just create...and sell..sell...sell.....

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...