Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

New page in The Information box. Help


scorpio33

Recommended Posts

I tried to create a F.A.Q. in my Information Box. I followed the instruction in the knowledge base. When i click on the F.A.Q. link in the information box i get this in the browser. http://gamesrealcheap.com/catalog/FILENAME_FAQ.

I know that i am supposed to see http://gamesrealcheap.com/catalog/FAQ.php but i don't know what is wrong.

Can someone please tell me how to fix this so that when i click on FAQ the browser shows that page. :(

 

My Website

 

Thanks

Link to comment
Share on other sites

go to contributions and download pagemaker

 

I have never done a contribution install. I am new to all of this. I am learning as i go.

Once i download the contribution, how do i install it on my website?

If i can acomplish this then i will be able to install some other contributions that i like.

How do upload the contribution? and then install it.

sorry about all the questions.

Thanks

Link to comment
Share on other sites

I have never done a contribution install. I am new to all of this. I am learning as i go.

Once i download the contribution, how do i install it on my website?

If i can acomplish this then i will be able to install some other contributions that i like.

How do upload the contribution? and then install it.

sorry about all the questions.

Thanks

I downloaded Pagemaker and installed it on my PC. I was unable to create a FAQ page. Runtime Error shows up instead. :(

 

Will someone please help me to create a FAQ page in my information box.

 

Thanks in advance

My Website

Link to comment
Share on other sites

Hi,

 

You're having almost the exact problem I was having recently. Check out this thread and see if it helps.

 

Make sure you've added the line

  define('FILENAME_FAQ', 'faq.php');

to catalog/includes/filenames.php, and not to catalog/admin/includes/filename.php

That's what someone figured out that I was doing wrong!

 

^_^ Hope this helps!

 

 

*checks your site again*

Wait, now I see what Mibble meant... you don't even have a faq.php file! o_0

 

Take another one of the Infobox pages (eg privacy.php). Download your /catalog/includes/privacy.php. Open it in your text editor (Pagemaker, 1stpage, Notepad - not Wordpad!) and change

$Id: privacy.php

to

$Id: faq.php

Change

  require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRIVACY);
 $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_PRIVACY));

to

  require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_FAQ);
 $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_FAQ));

Save it as faq.php

Upload it to /catalog/includes/faq.php

 

Download /catalog/includes/languages/english/privacy.php

Change

$Id: privacy.php

to

$Id: faq.php

Now change your information:

define('NAVBAR_TITLE', 'Privacy Notice');
define('HEADING_TITLE', 'Privacy Notice');

define('TEXT_INFORMATION', 'Put here your Privacy Notice information.');

To be something like

define('NAVBAR_TITLE', 'FAQ');
define('HEADING_TITLE', 'Frequently Asked Questions');

define('TEXT_INFORMATION', 'Put your text and/or HTML for your FAQ page here.  Be sure to leave the single quotes in place!');

 

Upload this one to /catalog/includes/languages/english/faq.php

 

I hope one of these solutions helps you! ^_^

Link to comment
Share on other sites

Hi,

 

You're having almost the exact problem I was having recently.  Check out this thread and see if it helps.

 

Make sure you've added the line

 ?define('FILENAME_FAQ', 'faq.php');

to catalog/includes/filenames.php, and not to catalog/admin/includes/filename.php

That's what someone figured out that I was doing wrong!

 

^_^ Hope this helps!

*checks your site again*

Wait, now I see what Mibble meant... you don't even have a faq.php file! o_0

 

Take another one of the Infobox pages (eg privacy.php).  Download your /catalog/includes/privacy.php.  Open it in your text editor (Pagemaker, 1stpage, Notepad - not Wordpad!)  and change

$Id: privacy.php

to

$Id: faq.php

Change

 ?require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRIVACY);
?$breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_PRIVACY));

to

 ?require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_FAQ);
?$breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_FAQ));

Save it as faq.php

Upload it to /catalog/includes/faq.php

 

Download /catalog/includes/languages/english/privacy.php

Change

$Id: privacy.php

to

$Id: faq.php

Now change your information:

define('NAVBAR_TITLE', 'Privacy Notice');
define('HEADING_TITLE', 'Privacy Notice');

define('TEXT_INFORMATION', 'Put here your Privacy Notice information.');

To be something like

define('NAVBAR_TITLE', 'FAQ');
define('HEADING_TITLE', 'Frequently Asked Questions');

define('TEXT_INFORMATION', 'Put your text and/or HTML for your FAQ page here. ?Be sure to leave the single quotes in place!');

 

Upload this one to /catalog/includes/languages/english/faq.php

 

I hope one of these solutions helps you! ^_^

I tried everything that was suggeated, but it is still not working.

Now i am getting an error when i click on FAQ in the information box.

 

Error

Warning: main(includes/languages/english/FILENAME_FAQ): failed to open stream: No such file or directory in /hsphere/local/home/ricky33/gamesrealcheap.com/catalog/faq.php on line 15

 

Fatal error: main(): Failed opening required 'includes/languages/english/FILENAME_FAQ' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/ricky33/gamesrealcheap.com/catalog/faq.php on line 15

Link to comment
Share on other sites

There's one thing left to do - in your includes/languages/english.php file, scroll down until you find the entries for the Information Box

 

// information box text in includes/boxes/information.php

 

and add the new file to that list.

 

Vger

Link to comment
Share on other sites

There's one thing left to do - in your includes/languages/english.php file, scroll down until you find the entries for the Information Box

 

// information box text in includes/boxes/information.php

 

and add the new file to that list.

 

Vger

I am not sure what you are telling me to do.

This is what my catalog/includes/language/english.php looks like.

 

// information box text in includes/boxes/information.phpdefine('BOX_HEADING_INFORMATION', 'Information');define('BOX_INFORMATION_PRIVACY', 'Privacy Notice');define('BOX_INFORMATION_CONDITIONS', 'Conditions of Use');define('BOX_INFORMATION_SHIPPING', 'Shipping & Returns');define('BOX_INFORMATION_CONTACT', 'Contact Us');define('BOX_INFORMATION_FAQ', 'FAQ');

Link to comment
Share on other sites

I am not sure what you are telling me to do.

This is what my catalog/includes/language/english.php looks like.

 

// information box text in includes/boxes/information.phpdefine('BOX_HEADING_INFORMATION', 'Information');define('BOX_INFORMATION_PRIVACY', 'Privacy Notice');define('BOX_INFORMATION_CONDITIONS', 'Conditions of Use');define('BOX_INFORMATION_SHIPPING', 'Shipping & Returns');define('BOX_INFORMATION_CONTACT', 'Contact Us');define('BOX_INFORMATION_FAQ', 'FAQ');

[right][post=490397]<{POST_SNAPBACK}>[/post][/right]

I still need help with my FAQ page.Now when i click on FAQ in the information box. the browser goes to the right address but i still can't see FAQ page. I get the error above.

Once Again

Help

Link to comment
Share on other sites

I still need help with my FAQ page.Now when i click on FAQ in the information box. the browser goes to the right address but i still can't see FAQ page. I get the error above.

Once Again

Help

 

Thanks to anyone who tried to help me with this problem.

 

FOUND IT :D

Problem caused by bad HTML here.

catalog/includes/languages/english/faq.php

 

Fix:

Deleted all the text on the page B)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...