Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

something missing in my configuration


dirthawker

Recommended Posts

I haven't played customer on my live site (just a local copy) until today. So I set up a login and tried to log in. And I got a 404!

It's trying to go to

https://host.lainterweb.com/catalog/index.php?osCsid=blabla

 

when it should be

https://host.lainterweb.com/flushnfly/catalog/index.php?osCsid=blabla

 

Here's the portion of configuration.php:

 

define('HTTP_SERVER', 'http://www.flushnfly.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://host.lainterweb.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.flushnfly.com');

define('HTTPS_COOKIE_DOMAIN', 'host.lainterweb.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/flushnfly/catalog/');

 

First Q: what's wrong?

2nd, 3rd and 4th Q: Why is it displaying the actual hostname, anyway? Shouldn't it be https://www.flushnfly.com/catalog/... ? How can I get it to display that and work correctly?

Incidentally, I tried https://www.flushnfly.com/catalog/ and it tried to give me a certificate for www.snakeoil.dom! WTF?

Link to comment
Share on other sites

I'm a moron. Nevermind.

 

Someone? Anyone?

 

My assumption is that the code plunks together HTTPS_SERVER with DIR_WS_HTTPS_CATALOG

... which ought to add up to https://host.lainterweb.com/flushnfly/catalog/

 

Is this something funky my ISP is doing or should I change HTTPS_SERVER to read

https://host.lainterweb.com/flushnfly/ ?

Link to comment
Share on other sites

Try this (but don't keep bumping posts)

 

define('HTTPS_SERVER', 'https://host.lainterweb.com/flushnfly');

 

and

 

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

 

Vger

 

 

I'll give it a shot. You've given many people excellent advice & help, Vger, I have confidence your solution will work. Sorry for panicking there, things were working so nicely on my local copy, it surprised me that the live might not work exactly the same. Plus I'd told the site owner it was ready to go :-"

-andrea-

 

Postscript: YES IT WORKED! Thanks!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...