Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Got customer info passed to verisign


ErikOS

Recommended Posts

I used some code that I found by SMILE on this forum. I passed the customer info minus credit card info but when I put the test credit card info in the verisign site it doesn't go through. Does any one know what could cause this

 

This is my code for passing customer info to verisign

 

SMITE

APR 7 2004, 06:50 PM

OK, AFTER GETTING FRUSTRATED AT THE WASTE OF MONEY THAT PAYFLOW WOULD BE IF CC INFO WERE SENT CLEAR TEXT, I BELIEVE I'VE MODIFIED IT TO ALLOW USE OF THE VERISIGN FORMS TO COLLECT THE INFO INSTEAD OF COLLECTING IT LOCALLY:

 

IN CATALOG/INCLUDES/MODULES/PAYMENT/PAYFLOWLINK.PHP:

 

COMMENT OUT LINES:

 

CODE

53: $FIELDS[1]=ARRAY('TITLE' => MODULE_PAYMENT_PAYFLOWLINK_TEXT_CREDIT_CARD_NUMBER,

 

THROUGH

 

CODE

70: '</TR></TABLE></TR></TABLE>');}

 

WHICH DISPLAY THE CC INPUT BOXES ON THE CHECKOUT PAGES.

 

COMMENT OUT EVERYTHING INSIDE OF THE PRE_CONFIRMATION_CHECK FUNCTION (81-115) SINCE THERE'S NOTHING TO PRE-CONFIRM.

 

FIND:

 

CODE

118: FUNCTION CONFIRMATION() {119: GLOBAL $HTTP_POST_VARS, $CARDNAME, $CARDNUMBER, $CHECKOUT_FORM_ACTION;

 

AND COMMENT OUT THE $CARDNAME, $CARDNUMBER, PART.

 

COMMENT OUT ALL THE FOLLOWING $FEILDS LINES (122-133)

 

 

FIND:

 

CODE

141: FUNCTION PROCESS_BUTTON() {142: GLOBAL $HTTP_POST_VARS, $CARDNAME, $CARDNUMBER, $ORDER, $TOTAL_TAX, $SHIPPING_COST;

 

AND COMMENT OUT THE $CARDNAME, $CARDNUMBER, PART.

 

COMMENT OUT THE FOLLOWING LINES THAT WOULD TRY TO SEND UN-COLLECTED THINGS TO VERISIGN:

 

CODE

150: TEP_DRAW_HIDDEN_FIELD('EXPDATE', $THIS->CC_EXPIRY_MONTH . $THIS->CC_EXPIRY_YEAR) .

 

 

CODE

154: TEP_DRAW_HIDDEN_FIELD('CARDNUM', $THIS->CC_CARD_NUMBER);155: IF (MODULE_PAYMENT_PAYFLOWLINK_CSC=="1"){156: $PROCESS_BUTTON_STRING .= TEP_DRAW_HIDDEN_FIELD('CSC', $HTTP_POST_VARS['PAYFLOWLINK_CC_CSC']);157: }

 

 

CODE

174: TEP_DRAW_HIDDEN_FIELD('ORDERFORM', 'FALSE') .

 

 

ALSO, SINCE YOU COMMENTED OUT LINE 154, YOU NEED TO CHANGE THE END OF LINE 153 FROM A . TO A ;

 

I'M SURE SOME OF THIS IS UNNECESSARY, BUT AFTER DOING ALL THIS, IT DOES SEEM TO WORK THE WAY WE WANT. GOOD LUCK!

 

 

HTTP://www.oscommerce.com/forums/LOFIVERSION/I...PHP/T38726.HTML

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...